summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Ng2021-03-02 00:22:51 +0800
committerDarren Ng2021-03-02 00:22:51 +0800
commit32bc85dcd459c6e64278d8be5afab1b06979a7d5 (patch)
treeada3e59ab8b2dae06dfa1c62741993bd1bee2395
parent8558f2c215894fc5a81821c3707bff60c3aaa548 (diff)
downloadaur-32bc85dcd459c6e64278d8be5afab1b06979a7d5.tar.gz
revert Makefile
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4965565afc77..71d4f3ef853e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ldid-git
pkgdesc = a tool used for ad-hoc codesigning iOS binaries - saurik official
pkgver = 2.1.2.r10.d4a4dbe
- pkgrel = 3
+ pkgrel = 4
url = https://git.saurik.com/ldid.git
arch = x86_64
license = AGPL3
diff --git a/PKGBUILD b/PKGBUILD
index 7afc459e5a4a..b31c8deb2147 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=ldid-git
pkgver=2.1.2.r10.d4a4dbe
-pkgrel=3
+pkgrel=4
pkgdesc="a tool used for ad-hoc codesigning iOS binaries - saurik official"
arch=(x86_64)
url="https://git.saurik.com/${pkgname//-/.}"
license=(AGPL3)
depends=(
libplist
- # libxml2
+ # libxml2 # libxml-2.0
openssl
)
makedepends=(git clang)
@@ -17,7 +17,7 @@ provides=(${pkgname%-git}{,2{,-git}})
conflicts=(${provides[*]})
# https://stackoverflow.com/questions/10909976/why-do-seemingly-empty-files-and-strings-produce-md5sums
source=(file:///dev/null)
-md5sums=('d41d8cd98f00b204e9800998ecf8427e')
+md5sums=(d41d8cd98f00b204e9800998ecf8427e)
prepare(){
cd "$srcdir"
@@ -38,16 +38,19 @@ pkgver(){
# https://www.gnu.org/software/make/manual/html_node/Implicit-Variables.html
# https://www.gnu.org/software/make/manual/html_node/Catalogue-of-Rules.html
build(){
+# Blame me or the upstream
+# clang -I. -c -o lookup2.o lookup2.c
+# clang++ -std=c++11 -o ldid lookup2.o ldid.cpp -I. -lcrypto -lplist-2.0 -lxml2
cd "$srcdir/${pkgname%-git}"
cat <<"EOM" >Makefile
#
CC:=/bin/false
CXX:=/bin/false
-CFLAGS:=$(CFLAGS) $(shell pkg-config --cflags libplist-2.0,libcrypto) # libxml-2.0
+CFLAGS:=$(CFLAGS) $(shell pkg-config --cflags libplist-2.0,libcrypto)
#
default: ldid
ldid: CC:=clang++
-ldid: LDLIBS:=$(shell pkg-config --libs libplist-2.0,libcrypto) # libxml-2.0
+ldid: LDLIBS:=$(shell pkg-config --libs libplist-2.0,libcrypto)
ldid: ldid.o lookup2.o
#
%.o: CC:=clang