summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-11-01 22:31:08 -0500
committerChris Severance2015-11-01 22:31:08 -0500
commit32cd9b620bc70d3ddb4fecbd18d51162bd055bb6 (patch)
tree495f14c2e8d046dd4d5734c1d4299cde105abaa4
downloadaur-32cd9b620bc70d3ddb4fecbd18d51162bd055bb6.tar.gz
Initial Import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..417c543c35dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hypercalc
+ pkgdesc = A calculator designed to calculate extremely large numbers without overflowing.
+ pkgver = 20150124
+ pkgrel = 1
+ url = http://mrob.com/pub/perl/hypercalc.html
+ arch = any
+ license = GPL
+ depends = perl
+ source = http://mrob.com/pub/comp/hypercalc/hypercalc.txt
+ sha256sums = 9db69045904a1c2f715b9e2ab78888fdcdf32d33b4cb4683511811edfb9fe89a
+
+pkgname = hypercalc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..957cc3aada26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Simon Hollingshead <me at [firstnamelastname] dot com>
+
+set -u
+pkgname='hypercalc'
+pkgver='20150124'
+pkgrel='1'
+pkgdesc='A calculator designed to calculate extremely large numbers without overflowing.'
+arch=('any')
+url='http://mrob.com/pub/perl/hypercalc.html'
+license=('GPL')
+depends=('perl')
+source=("http://mrob.com/pub/comp/${pkgname}/${pkgname}.txt")
+sha256sums=('9db69045904a1c2f715b9e2ab78888fdcdf32d33b4cb4683511811edfb9fe89a')
+
+package() {
+ set -u
+ mkdir -p "${pkgdir}/usr/bin"
+ install -T "${srcdir}/${pkgname}.txt" "${pkgdir}/usr/bin/${pkgname}"
+ set +u
+}
+set +u