summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksey Filippov2018-03-01 17:08:20 +0000
committerAleksey Filippov2018-03-01 17:10:36 +0000
commit32db98eef250b2178cfb4f0ea0d89e299c0d932e (patch)
treeecb391ffa9db7f7858a8af8eb10a8b763f6073d4
downloadaur-32db98eef250b2178cfb4f0ea0d89e299c0d932e.tar.gz
Initial python-wheezy-0.1.167
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD53
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..348abe0eac05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Mar 1 17:10:35 UTC 2018
+pkgbase = python-wheezy
+ pkgdesc = A lightweight template library
+ pkgver = 0.1.167
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/wheezy.template
+ arch = any
+ license = MIT
+ depends = python
+ conflicts = python2-wheezy
+ source = https://pypi.python.org/packages/b1/67/7f0a14a4cc9bd949b8d22383c26fec83a00e7bd428e15c697f998e3e37ba/wheezy.template-0.1.167.tar.gz
+ sha256sums = a2ee933452f0352fb8587d79bf6fc66dbf3a14779ef7d17b9fa75e80c0003f19
+
+pkgname = python-wheezy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4c587b92a48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Copyright 2018 Google LLC
+
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+
+# http://www.apache.org/licenses/LICENSE-2.0
+
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# Maintainer: Aleksey Filippov <sarum9in@gmail.com>
+_pkgname=wheezy.template
+pkgname=python-wheezy
+pkgver=0.1.167
+pkgrel=1
+epoch=
+pkgdesc="A lightweight template library"
+arch=('any')
+url="https://pypi.python.org/pypi/wheezy.template"
+license=('MIT')
+groups=()
+depends=('python')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=(
+ 'python2-wheezy' # /usr/bin/wheezy.template
+)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://pypi.python.org/packages/b1/67/7f0a14a4cc9bd949b8d22383c26fec83a00e7bd428e15c697f998e3e37ba/wheezy.template-${pkgver}.tar.gz")
+noextract=()
+sha256sums=('a2ee933452f0352fb8587d79bf6fc66dbf3a14779ef7d17b9fa75e80c0003f19')
+validpgpkeys=()
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ chmod +rwX -R "$pkgdir" # by default installs with 700
+}