summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2016-02-17 23:54:15 +0100
committerDario Ostuni2016-02-17 23:54:15 +0100
commit32dc82f8d751a0d64d2a1af9c9dc8a5cd8b2e2e8 (patch)
tree948a7e721193c7b1fe50ee9bea1603a90b26fc2e
downloadaur-32dc82f8d751a0d64d2a1af9c9dc8a5cd8b2e2e8.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94069326b53e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Feb 17 22:54:09 UTC 2016
+pkgbase = mingw-w64-yaml-cpp
+ pkgdesc = YAML parser and emitter in C++, written around the YAML 1.2 spec (mingw-w64)
+ pkgver = 0.5.3
+ pkgrel = 1
+ url = https://github.com/jbeder/yaml-cpp
+ arch = any
+ license = MIT
+ makedepends = mingw-w64-boost
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-crt
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = https://github.com/jbeder/yaml-cpp/archive/release-0.5.3.tar.gz
+ md5sums = 64200ca0bf5e0af065804d8d3e8f6d42
+
+pkgname = mingw-w64-yaml-cpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10d64bbbbaef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Dario Ostuni <another.code.996@gmail.com>
+
+_pkgname=yaml-cpp
+pkgname=mingw-w64-${_pkgname}
+pkgver=0.5.3
+pkgrel=1
+pkgdesc="YAML parser and emitter in C++, written around the YAML 1.2 spec (mingw-w64)"
+url="https://github.com/jbeder/yaml-cpp"
+arch=('any')
+license=('MIT')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-boost' 'mingw-w64-cmake' 'mingw-w64-gcc')
+source=(https://github.com/jbeder/yaml-cpp/archive/release-${pkgver}.tar.gz)
+md5sums=('64200ca0bf5e0af065804d8d3e8f6d42')
+options=(staticlibs !strip !buildflags)
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd $srcdir/${_pkgname}-release-$pkgver
+ unset LDFLAGS
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake .. -DCMAKE_INSTALL_PREFIX=/usr/${_arch} -DBUILD_SHARED_LIBS=ON
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir/${_pkgname}-release-$pkgver/build-${_arch}"
+
+ make DESTDIR=$pkgdir install
+
+ install -Dm644 yaml-cpp-config.cmake $pkgdir/usr/${_arch}/lib/cmake/${_pkgname}/yaml-cpp-config.cmake
+ install -Dm644 yaml-cpp-config-version.cmake $pkgdir/usr/${_arch}/lib/cmake/${_pkgname}/yaml-cpp-config-version.cmake
+ install -Dm644 yaml-cpp-targets.cmake $pkgdir/usr/${_arch}/lib/cmake/${_pkgname}/yaml-cpp-targets.cmake
+
+ find "$pkgdir/usr/${_arch}" -name '*.exe' | xargs -rtl1 rm
+ find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip --strip-unneeded
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
+ done
+}