summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorservices.build-monitoring2023-10-17 15:27:08 +0200
committerservices.build-monitoring2023-10-17 15:27:08 +0200
commit32ded8d347a86f42bf3908ecac1e963145ba3f9f (patch)
tree854242d166c1419a7e4421a86d6d11fd57f27622
parentf402fb6343b74a79bc05d86f1f3ad7cf3fdd4895 (diff)
downloadaur-32ded8d347a86f42bf3908ecac1e963145ba3f9f.tar.gz
Bump version to 1.2. Fix dependencies, license name and meson build options
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
-rw-r--r--exif.patch13
3 files changed, 33 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 750a0985d84a..37e460b3f274 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = siril
pkgdesc = An astronomical image processing software for Linux. (IRIS clone)
- pkgver = 1.0.6
+ pkgver = 1.2.0
pkgrel = 1
url = https://www.siril.org/
arch = x86_64
- license = GPLv3
+ license = GPL3
makedepends = meson
makedepends = cmake
makedepends = ninja
@@ -17,14 +17,16 @@ pkgbase = siril
depends = opencv
depends = exiv2
depends = gnuplot
+ depends = ffms2
optdepends = libpng: PNG import
optdepends = libjpeg: JPEG import and export
optdepends = libtiff: TIFF import and export
optdepends = libraw: DSLR RAW images import
- optdepends = ffms2: films native support as image sequences and import
optdepends = libcurl-gnutls: check for updates
optdepends = gnuplot: photometry graphs creation
- source = https://free-astro.org/download/siril-1.0.6.tar.bz2
- sha256sums = f89604697ffcd43f009f8b4474daafdef220a4f786636545833be1236f38b561
+ source = https://free-astro.org/download/siril-1.2.0.tar.bz2
+ source = exif.patch
+ sha256sums = 5941a4b5778929347482570dab05c9d780f3ab36e56f05b6301c39d911065e6f
+ sha256sums = 5d45fc3d67d5310b874db696880ab827fe8d9b0a6546d13e7b387d1ec09f6957
pkgname = siril
diff --git a/PKGBUILD b/PKGBUILD
index 51c45642a0f5..3d7309a2f7f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,34 @@
# Contributor: Vincent Hourdin <vh|at|free-astro=DOT=vinvin.tf>
pkgname=siril
-pkgver='1.0.6'
+pkgver='1.2.0'
pkgrel=1
pkgdesc="An astronomical image processing software for Linux. (IRIS clone)"
arch=('x86_64')
-license=('GPLv3')
-depends=('gtk3' 'json-glib' 'fftw' 'cfitsio' 'gsl' 'libconfig' 'opencv' 'exiv2' 'gnuplot')
+license=('GPL3')
+depends=('gtk3' 'json-glib' 'fftw' 'cfitsio' 'gsl' 'libconfig' 'opencv' 'exiv2' 'gnuplot' 'ffms2')
makedepends=('meson' 'cmake' 'ninja')
url="https://www.siril.org/"
optdepends=('libpng: PNG import'
'libjpeg: JPEG import and export'
'libtiff: TIFF import and export'
'libraw: DSLR RAW images import'
- 'ffms2: films native support as image sequences and import'
'libcurl-gnutls: check for updates'
'gnuplot: photometry graphs creation')
-source=("https://free-astro.org/download/siril-${pkgver}.tar.bz2")
-sha256sums=('f89604697ffcd43f009f8b4474daafdef220a4f786636545833be1236f38b561')
+source=("https://free-astro.org/download/siril-${pkgver}.tar.bz2" "exif.patch")
+sha256sums=('5941a4b5778929347482570dab05c9d780f3ab36e56f05b6301c39d911065e6f' '5d45fc3d67d5310b874db696880ab827fe8d9b0a6546d13e7b387d1ec09f6957')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ pwd
+ patch -Np1 < ../exif.patch
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver/"
- meson --prefix /usr --buildtype release _build
+ meson setup --prefix /usr --buildtype release _build
ninja -C _build
}
diff --git a/exif.patch b/exif.patch
new file mode 100644
index 000000000000..b61607fd1e2d
--- /dev/null
+++ b/exif.patch
@@ -0,0 +1,13 @@
+--- a/src/core/exif.cpp 2023-09-15 10:21:26.000000000 +0200
++++ b/src/core/exif.cpp 2023-10-17 15:14:49.642653101 +0200
+@@ -124,7 +124,7 @@
+ gchar* siril_get_date_from_exif(const char *filename) {
+ #ifdef HAVE_EXIV2
+ try {
+- Exiv2::Image::AutoPtr image = Exiv2::ImageFactory::open(WIDEN(filename));
++ Exiv2::Image::UniquePtr image = Exiv2::ImageFactory::open(WIDEN(filename));
+ if (image.get() == 0) {
+ fprintf(stderr, "Error Cannot open the file.\n");
+ return NULL;
+
+