summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2017-05-11 09:57:09 -0400
committerErik Dubois2017-05-11 09:57:09 -0400
commit32e1c20148b04d25ff295086a50666d4b4647e6b (patch)
tree78df67b26f0fb8ce627b4ac35ad941cb3bbad33c
downloadaur-32e1c20148b04d25ff295086a50666d4b4647e6b.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--45-source-serif-pro.conf12
-rw-r--r--90-tt-source-serif-pro.conf26
-rw-r--r--PKGBUILD40
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72c1c89eb90e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu May 11 13:57:01 UTC 2017
+pkgbase = ttf-source-serif-pro-ibx
+ pkgdesc = Source Serif Pro is a serif typeface in the transitional style, designed to complement Source Sans. TrueType version.
+ pkgver = 2.000
+ pkgrel = 1
+ url = http://www.adobe.com/
+ arch = any
+ groups = infinality-bundle-fonts-extra
+ license = custom:OFL
+ depends = fontconfig
+ conflicts = adobe-source-serif-pro-fonts
+ conflicts = otf-source-serif-pro-ibx
+ source = https://github.com/adobe-fonts/source-serif-pro/archive/2.000R.tar.gz
+ source = 45-source-serif-pro.conf
+ source = 90-tt-source-serif-pro.conf
+ sha1sums = 7117eda1c75894630a220a67a2110e1c96e688e6
+ sha1sums = ec79743b49b83d380ca86918c7c44d474fd5101d
+ sha1sums = 19dfa23495d142c728f8947b5eefd169f495e82e
+
+pkgname = ttf-source-serif-pro-ibx
+
diff --git a/45-source-serif-pro.conf b/45-source-serif-pro.conf
new file mode 100644
index 000000000000..1f97ff6fcc90
--- /dev/null
+++ b/45-source-serif-pro.conf
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Source Serif Pro</family>
+ <default>
+ <family>serif</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/90-tt-source-serif-pro.conf b/90-tt-source-serif-pro.conf
new file mode 100644
index 000000000000..3a08b4f23a21
--- /dev/null
+++ b/90-tt-source-serif-pro.conf
@@ -0,0 +1,26 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Source Serif Pro</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintfull</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdeca6a1f430
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: bohoomil <@zoho.com>
+
+pkgname=ttf-source-serif-pro-ibx
+pkgver=2.000
+pkgrel=1
+depends=('fontconfig')
+pkgdesc="Source Serif Pro is a serif typeface in the transitional style, designed to complement Source Sans. TrueType version."
+url="http://www.adobe.com/"
+arch=('any')
+license=('custom:OFL')
+conflicts=('adobe-source-serif-pro-fonts' 'otf-source-serif-pro-ibx')
+groups=('infinality-bundle-fonts-extra')
+source=("https://github.com/adobe-fonts/source-serif-pro/archive/${pkgver}R.tar.gz"
+ 45-source-serif-pro.conf
+ 90-tt-source-serif-pro.conf)
+sha1sums=('7117eda1c75894630a220a67a2110e1c96e688e6'
+ 'ec79743b49b83d380ca86918c7c44d474fd5101d'
+ '19dfa23495d142c728f8947b5eefd169f495e82e')
+
+package(){
+ cd "source-serif-pro-${pkgver}R"
+
+ install -m755 -d "${pkgdir}"/usr/share/licenses/"${pkgname}"
+ install -m644 LICENSE.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"
+
+ install -m755 -d "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 TTF/*.ttf "${pkgdir}"/usr/share/fonts/"${pkgname}"
+
+ cd "${srcdir}"
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.avail
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.d
+ install -m644 45-source-serif-pro.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/45-source-serif-pro.conf
+ install -m644 90-tt-source-serif-pro.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/90-tt-source-serif-pro.conf
+
+ cd "${pkgdir}"/etc/fonts/conf.d
+ ln -s ../conf.avail/45-source-serif-pro.conf .
+ ln -s ../conf.avail/90-tt-source-serif-pro.conf .
+}