summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-11-04 01:39:29 +0800
committerUniversebenzene2023-11-04 01:39:29 +0800
commit3328a780a1410e5704c7e361c1b98b479029253f (patch)
tree638b31e1fcc0003fb6975339dcf9cda40ff7b307
parent327609b6e99809c77bb0adee22fc2c3fa6057caa (diff)
downloadaur-3328a780a1410e5704c7e361c1b98b479029253f.tar.gz
Update to version 1.2.23
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
-rw-r--r--revert-inside-png-path.patch12
3 files changed, 41 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e38fccd2207c..8f25f5e1a9fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-spherical_geometry
pkgdesc = Python based tools for spherical geometry
- pkgver = 1.2.22
+ pkgver = 1.2.23
pkgrel = 1
url = http://www.stsci.edu/resources/software_hardware/stsci_python
arch = i686
@@ -9,22 +9,27 @@ pkgbase = python-spherical_geometry
checkdepends = python-pytest
checkdepends = python-astropy
makedepends = python-setuptools-scm
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = qd>=2.3.24
makedepends = python-numpy
- makedepends = qd>=2.3.7
makedepends = python-sphinx-automodapi
makedepends = python-numpydoc
- source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.22.tar.gz
+ source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.23.tar.gz
source = fix_typo.patch
source = fix_doc_warning.patch
- md5sums = 8537874297c128da8933416284356e68
+ source = revert-inside-png-path.patch
+ md5sums = ad72571c6f83a80b49e033685a24d8c0
md5sums = 376f76ebdf3c52048a113c386c091210
md5sums = fed5395d45a2275ccd5e0d63956ecddf
+ md5sums = ad61482f989d4df861753edc5af0f920
pkgname = python-spherical_geometry
- depends = python>=3.6
- depends = python-numpy>=1.10.0
- depends = qd>=2.3.7
- depends = python-astropy>=0.4
+ depends = python>=3.8
+ depends = python-numpy>=1.18
+ depends = qd>=2.3.24
+ depends = python-astropy>=5.0.4
optdepends = python-spherical_geometry-doc: Documentation for Spherical Geometry Toolkit
pkgname = python-spherical_geometry-doc
diff --git a/PKGBUILD b/PKGBUILD
index 161c30927c8d..742f7bb99764 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,30 @@
pkgbase=python-spherical_geometry
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=1.2.22
+pkgver=1.2.23
pkgrel=1
pkgdesc="Python based tools for spherical geometry"
arch=('i686' 'x86_64')
url="http://www.stsci.edu/resources/software_hardware/stsci_python"
license=('BSD')
makedepends=('python-setuptools-scm'
+ 'python-wheel'
+ 'python-build'
+ 'python-installer'
+ 'qd>=2.3.24'
'python-numpy'
- 'qd>=2.3.7'
'python-sphinx-automodapi'
'python-numpydoc')
checkdepends=('python-pytest'
'python-astropy')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
'fix_typo.patch'
- 'fix_doc_warning.patch')
-md5sums=('8537874297c128da8933416284356e68'
+ 'fix_doc_warning.patch'
+ 'revert-inside-png-path.patch')
+md5sums=('ad72571c6f83a80b49e033685a24d8c0'
'376f76ebdf3c52048a113c386c091210'
- 'fed5395d45a2275ccd5e0d63956ecddf')
+ 'fed5395d45a2275ccd5e0d63956ecddf'
+ 'ad61482f989d4df861753edc5af0f920')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
@@ -31,12 +36,14 @@ prepare() {
# patch -Np1 -i "${srcdir}/fix_doc_warning.patch"
patch -Np1 -i "${srcdir}/fix_typo.patch"
+ patch -Np1 -i "${srcdir}/revert-inside-png-path.patch"
+ sed -i "/oldest-supported-numpy/s/, \"oldest-supported-numpy\"//" pyproject.toml
export USE_SYSTEM_QD=1
}
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
msg "Building Docs"
NUMPY_EXPERIMENTAL_DTYPE_API=1 PYTHONPATH="../build/lib.linux-${CARCH}-cpython-$(get_pyver)" \
@@ -48,19 +55,18 @@ check() {
cp "build/lib.linux-${CARCH}-cpython-$(get_pyver)/${_pyname}/math_util.cpython-$(get_pyver)-${CARCH}-linux-gnu.so" "${_pyname}"
NUMPY_EXPERIMENTAL_DTYPE_API=1 pytest \
- --deselect=spherical_geometry/tests/test_union.py::test_difficult_unions || warning "Tests failed" # -vv --color=yes
-# NUMPY_EXPERIMENTAL_DTYPE_API=1 PYTHONPATH="build/lib.linux-${CARCH}-cpython-$(get_pyver)" pytest -vv --color=yes #"build/lib.linux-${CARCH}-cpython-$(get_pyver)" #\
+ --deselect=spherical_geometry/tests/test_union.py::test_difficult_unions || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
}
package_python-spherical_geometry() {
- depends=('python>=3.6' 'python-numpy>=1.10.0' 'qd>=2.3.7' 'python-astropy>=0.4')
+ depends=('python>=3.8' 'python-numpy>=1.18' 'qd>=2.3.24' 'python-astropy>=5.0.4')
optdepends=('python-spherical_geometry-doc: Documentation for Spherical Geometry Toolkit')
cd ${srcdir}/${_pyname}-${pkgver}
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}/"
install -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" licenses/*
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}
package_python-spherical_geometry-doc() {
diff --git a/revert-inside-png-path.patch b/revert-inside-png-path.patch
new file mode 100644
index 000000000000..7b194952ed8f
--- /dev/null
+++ b/revert-inside-png-path.patch
@@ -0,0 +1,12 @@
+diff --color -ura a/README.rst b/README.rst
+--- a/README.rst 2022-10-22 07:06:08.000000000 +0800
++++ b/README.rst 2023-10-28 18:54:38.065364597 +0800
+@@ -107,7 +107,7 @@
+ declares that the area of the polygon is the green region, and not the
+ white region.
+
+-.. image:: docs/spherical_geometry/inside.png
++.. image:: inside.png
+
+ The inside point of the the polygon can be obtained from the
+ ``~polygon.SphericalPolygon.inside`` property.