summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasm0dey2019-06-05 21:11:29 +0300
committerasm0dey2019-06-05 21:11:29 +0300
commit33424ee6206f5df0ffd93652b9e26f9eda20f62c (patch)
tree40b4bbb7c6ff92fcde948c66ceb45eabc4dfdf27
downloadaur-33424ee6206f5df0ffd93652b9e26f9eda20f62c.tar.gz
Initial
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore52
-rw-r--r--PKGBUILD33
3 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2b754ffcea9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cb-git
+ pkgdesc = Find files with SQL-like queries
+ pkgver = 0.1.0.r1.g036df74
+ pkgrel = 1
+ url = https://github.com/yaa110/cb
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ depends = gcc-libs
+ provides = cb
+ conflicts = cb
+ conflicts = cb-bin
+ source = cb::git://github.com/yaa110/cb.git
+ sha512sums = SKIP
+
+pkgname = cb-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..29cc57d4bd61
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,52 @@
+
+# Created by https://www.gitignore.io/api/vim,visualstudiocode,archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=vim,visualstudiocode,archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+### Vim ###
+# Swap
+[._]*.s[a-v][a-z]
+[._]*.sw[a-p]
+[._]s[a-rt-v][a-z]
+[._]ss[a-gi-z]
+[._]sw[a-p]
+
+# Session
+Session.vim
+
+# Temporary
+.netrwhist
+*~
+# Auto-generated tag files
+tags
+# Persistent undo
+[._]*.un~
+
+### VisualStudioCode ###
+.vscode/*
+!.vscode/settings.json
+!.vscode/tasks.json
+!.vscode/launch.json
+!.vscode/extensions.json
+
+### VisualStudioCode Patch ###
+# Ignore all local history of files
+.history
+
+# End of https://www.gitignore.io/api/vim,visualstudiocode,archlinuxpackages
+LICENSE*
+cb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c50a952bf603
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: asm0dey <pavel.finkelshtein@gmail.com>
+
+pkgname=cb-git
+_pkgname=cb
+pkgver=0.1.0.r1.g036df74
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/yaa110/cb"
+license=("MIT")
+
+pkgdesc='Find files with SQL-like queries'
+
+source=("$_pkgname::git://github.com/yaa110/cb.git")
+sha512sums=('SKIP')
+makedepends=('rust')
+depends=('gcc-libs')
+conflicts=('cb' 'cb-bin')
+provides=('cb')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ cargo build --release
+}
+
+package() {
+ install -Dm755 "$_pkgname/target/release/cli" "$pkgdir/usr/bin/cb"
+ install -Dm644 "$_pkgname/LICENSE-MIT" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}