summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Cooper2023-12-21 22:01:22 -0500
committerDavid Cooper2023-12-27 18:51:18 -0500
commit337b1376917aae901b99cae6afa76f148099a98c (patch)
treeab6f4cf9069e07c013ed7a4ecbf94e7727009c0a
parent16c8b4bba9d91286e8dd7873e00e0ea63b94b381 (diff)
downloadaur-337b1376917aae901b99cae6afa76f148099a98c.tar.gz
Update to 0.1.40
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD15
3 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed8678c363c9..837f4bd1247a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = butt
pkgdesc = Easy to use, multi OS streaming tool
- pkgver = 0.1.37
+ pkgver = 0.1.40
pkgrel = 1
- url = http://butt.sourceforge.net/
+ url = https://danielnoethen.de/butt/
arch = i686
arch = x86_64
arch = aarch64
@@ -18,7 +18,7 @@ pkgbase = butt
depends = flac
depends = opus
depends = libsamplerate
- source = butt-0.1.37.tar.gz::http://sourceforge.net/projects/butt/files/butt/butt-0.1.37/butt-0.1.37.tar.gz
- b2sums = 1166c54672217e24ef604247d2dd56a68a2f36f6f59e94149b70d55b0c576f17b6c9ad11e829a0244096efde759bc459e0c6ae5e737b1f98067689d25669da57
+ source = butt-0.1.40.tar.gz::https://danielnoethen.de/butt/release/0.1.40/butt-0.1.40.tar.gz
+ b2sums = 920680b90dc4a0936e2fac4cb155ed11f041b440bff3e6ca696b4bf633395550c7bbcf1fceb8f4aeedd0edf7e0d3be009874a7b141961b1bc34f867e16c4381a
pkgname = butt
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a859e214ca41
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+butt-*
diff --git a/PKGBUILD b/PKGBUILD
index f6460c532864..b37fc46beb17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: linuxer <linuxer@artixlinux.org>
# Maintainer: Josef Miegl <josef@miegl.cz>
+# Maintainer: David Cooper (dtcooper) <david@dtcooper.com>
# Contributor: goll <adrian.goll+aur[at]gmail>
# Contributor: Kosava <kosava@gmail.com>
pkgname=butt
-pkgver=0.1.37
+pkgver=0.1.40
pkgrel=1
pkgdesc="Easy to use, multi OS streaming tool"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=('GPL2')
-url="http://butt.sourceforge.net/"
+url="https://danielnoethen.de/butt/"
depends=('fltk' 'dbus' 'portaudio' 'libfdk-aac' 'libvorbis' 'libogg' 'lame' 'flac' 'opus' 'libsamplerate')
-source=(${pkgname}-${pkgver}.tar.gz::"http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz")
-b2sums=('1166c54672217e24ef604247d2dd56a68a2f36f6f59e94149b70d55b0c576f17b6c9ad11e829a0244096efde759bc459e0c6ae5e737b1f98067689d25669da57')
+source=("${pkgname}-${pkgver}.tar.gz::https://danielnoethen.de/${pkgname}/release/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+b2sums=('920680b90dc4a0936e2fac4cb155ed11f041b440bff3e6ca696b4bf633395550c7bbcf1fceb8f4aeedd0edf7e0d3be009874a7b141961b1bc34f867e16c4381a')
build() {
cd "${pkgname}-${pkgver}"
@@ -36,13 +37,15 @@ package() {
install -Dm644 "icons/icon_scalable.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
# Documentation
- for doc in AUTHORS ChangeLog KNOWN_BUGS NEWS README THANKS; do
+ for doc in AUTHORS ChangeLog COPYING KNOWN_BUGS NEWS README THANKS; do
install -Dm644 "${doc}" "${pkgdir}/usr/share/doc/${pkgname}/${doc}"
done
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s "/usr/share/doc/${pkgname}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
# Pixmaps
for file in usr/share/pixmaps/"${pkgname}"*; do
- filename=`basename "${file}"`
+ filename="$(basename "${file}")"
install -Dm644 "${file}" "${pkgdir}/usr/share/pixmaps/${filename}"
done
}