summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Beck2018-05-30 18:54:16 -0500
committerMax Beck2018-05-30 18:54:16 -0500
commit337c4cb72945039cb51aed8ce9958293f647bcbf (patch)
tree2043b6a9736227dd6928d759258565554b618a76
downloadaur-337c4cb72945039cb51aed8ce9958293f647bcbf.tar.gz
init
-rw-r--r--.SRCINFO55
-rw-r--r--PKGBUILD51
-rw-r--r--mpd.conf6
-rw-r--r--no_resid_builder.patch10
-rw-r--r--sysusers.d2
-rw-r--r--tmpfiles.d3
6 files changed, 127 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25f3bbb209cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,55 @@
+pkgbase = mpd-sidplay
+ pkgdesc = Flexible, powerful, server-side application for playing music - built with sidplay support
+ pkgver = 0.20.20
+ pkgrel = 1
+ url = https://www.musicpd.org/
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = doxygen
+ depends = libao
+ depends = ffmpeg
+ depends = libmodplug
+ depends = audiofile
+ depends = libshout
+ depends = libmad
+ depends = curl
+ depends = faad2
+ depends = sqlite
+ depends = jack
+ depends = libmms
+ depends = wavpack
+ depends = avahi
+ depends = libid3tag
+ depends = yajl
+ depends = libmpdclient
+ depends = icu
+ depends = libupnp
+ depends = libnfs
+ depends = libsamplerate
+ depends = libsoxr
+ depends = smbclient
+ depends = libgme
+ depends = zziplib
+ depends = libsystemd
+ depends = libsidplayfp
+ provides = mpd=0.20.20
+ conflicts = mpd
+ replaces = mpd
+ backup = etc/mpd.conf
+ source = https://www.musicpd.org/download/mpd/0.20/mpd-0.20.20.tar.xz
+ source = https://www.musicpd.org/download/mpd/0.20/mpd-0.20.20.tar.xz.sig
+ source = tmpfiles.d
+ source = sysusers.d
+ source = mpd.conf
+ source = no_resid_builder.patch
+ validpgpkeys = 0392335A78083894A4301C43236E8A58C6DB4512
+ sha256sums = a9e458c6e07cdf62649de7722e1e5a7f13aa82eeb397bfbbebc07cf5cf273584
+ sha256sums = SKIP
+ sha256sums = e09e38ab5fd6e8b3b3e6e5a48d837c164ad37aec7e6762a78810c34fe9abf3a1
+ sha256sums = 2679014448e9352e20e85d8d76b021aeebe27bdf6100b24577afee2f37522a95
+ sha256sums = a30c2c43824b540300cc83505c146989b415189bd90f191aebaed6f13556e6d2
+ sha256sums = 1ad209f027670ecaf5dd3a0c9daf9cf7758ab266090a1e4cf0caf226ee9b42ed
+
+pkgname = mpd-sidplay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26aea296a483
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Max Beck <rytonemail@gmail.com>
+pkgname=mpd-sidplay
+_pkgname=mpd
+pkgver=0.20.20
+_majorver=0.20
+pkgrel=1
+pkgdesc="Flexible, powerful, server-side application for playing music - built with sidplay support"
+url="https://www.musicpd.org/"
+license=("GPL")
+arch=("x86_64")
+depends=("libao" "ffmpeg" "libmodplug" "audiofile" "libshout" "libmad" "curl" "faad2" "sqlite" "jack" "libmms" "wavpack" "avahi" "libid3tag" "yajl" "libmpdclient" "icu" "libupnp" "libnfs" "libsamplerate" "libsoxr" "smbclient" "libgme" "zziplib" "libsystemd" "libsidplayfp")
+makedepends=("boost" "doxygen")
+validpgpkeys=('0392335A78083894A4301C43236E8A58C6DB4512')
+provides=("mpd=$pkgver")
+conflicts=("mpd")
+replaces=("mpd")
+source=("https://www.musicpd.org/download/${_pkgname}/${_majorver}/${_pkgname}-${pkgver}.tar.xz"{,.sig} "tmpfiles.d" "sysusers.d" "mpd.conf" "no_resid_builder.patch")
+sha256sums=("a9e458c6e07cdf62649de7722e1e5a7f13aa82eeb397bfbbebc07cf5cf273584" "SKIP" "e09e38ab5fd6e8b3b3e6e5a48d837c164ad37aec7e6762a78810c34fe9abf3a1" "2679014448e9352e20e85d8d76b021aeebe27bdf6100b24577afee2f37522a95" "a30c2c43824b540300cc83505c146989b415189bd90f191aebaed6f13556e6d2" "1ad209f027670ecaf5dd3a0c9daf9cf7758ab266090a1e4cf0caf226ee9b42ed")
+backup=("etc/mpd.conf")
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ patch < ../no_resid_builder.patch
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-jack \
+ --enable-libmpdclient \
+ --enable-pipe-output \
+ --enable-pulse \
+ --enable-soundcloud \
+ --enable-zzip \
+ --enable-sidplay \
+ --with-systemduserunitdir=/usr/lib/systemd/user \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 ../mpd.conf "${pkgdir}"/etc/mpd.conf
+ install -Dm644 ../tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/mpd.conf
+ install -Dm644 ../sysusers.d "${pkgdir}"/usr/lib/sysusers.d/mpd.conf
+
+ sed '/\[Service\]/a User=mpd' -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
+ sed '/WantedBy=/c WantedBy=default.target' -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
+}
diff --git a/mpd.conf b/mpd.conf
new file mode 100644
index 000000000000..175eacabdebe
--- /dev/null
+++ b/mpd.conf
@@ -0,0 +1,6 @@
+# See /usr/share/doc/mpd/mpdconf.example
+
+pid_file "/run/mpd/mpd.pid"
+db_file "/var/lib/mpd/mpd.db"
+state_file "/var/lib/mpd/mpdstate"
+playlist_directory "/var/lib/mpd/playlists" \ No newline at end of file
diff --git a/no_resid_builder.patch b/no_resid_builder.patch
new file mode 100644
index 000000000000..865a6a02b121
--- /dev/null
+++ b/no_resid_builder.patch
@@ -0,0 +1,10 @@
+--- configure.ac.old 2018-05-13 08:31:04.000000000 -0500
++++ configure.ac 2018-05-30 17:58:54.165666666 -0500
+@@ -1017,7 +1017,6 @@
+ fi
+
+ if test x$enable_sidplay = xyes; then
+- SIDPLAY_LIBS="$SIDPLAY_LIBS -lresid-builder"
+ AC_DEFINE(ENABLE_SIDPLAY, 1, [Define for libsidplay2 support])
+ if test x$found_sidplayfp = xyes; then
+ AC_DEFINE(HAVE_SIDPLAYFP, 1, [Define if libsidplayfp is used instead of libsidplay2])
diff --git a/sysusers.d b/sysusers.d
new file mode 100644
index 000000000000..6196e5ee9c7f
--- /dev/null
+++ b/sysusers.d
@@ -0,0 +1,2 @@
+u mpd 45 - /var/lib/mpd
+m mpd audio \ No newline at end of file
diff --git a/tmpfiles.d b/tmpfiles.d
new file mode 100644
index 000000000000..4931606bf517
--- /dev/null
+++ b/tmpfiles.d
@@ -0,0 +1,3 @@
+d /run/mpd 0755 mpd mpd
+d /var/lib/mpd 0755 mpd mpd
+d /var/lib/mpd/playlists 0755 mpd mpd \ No newline at end of file