summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Falkenberg2021-06-12 08:04:15 +0200
committerRobert Falkenberg2021-06-12 08:04:15 +0200
commit33831d06a6b6a95eecae7368766206354e8351d0 (patch)
treee9da8461cf587e9748639b3196b3412855ecf171
parent52843552dec85e0b6a211fb34617a4dfe95743c7 (diff)
downloadaur-33831d06a6b6a95eecae7368766206354e8351d0.tar.gz
Fix build against Boost 1.76
Add/Fix includes for boost::math::sign as emerge since Boost 1.76
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--boost-1.76.patch46
3 files changed, 58 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a62bc77ab5a..62f93bfec349 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libuhd3
pkgdesc = Universal Software Radio Peripheral (USRP) userspace driver
pkgver = 3.15.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://files.ettus.com/manual/
arch = x86_64
license = GPL
@@ -19,9 +19,10 @@ pkgbase = libuhd3
source = libuhd-3.15.0.0.tar.gz::https://github.com/EttusResearch/uhd/archive/v3.15.0.0.tar.gz
source = boost-1.73.patch
source = gcc-11.1.patch
+ source = boost-1.76.patch
sha256sums = eed4a77d75faafff56be78985950039f8d9d1eb9fcbd58b8862e481dd49825cd
sha256sums = 10c2f221dee97418f92d10606f9b9fea1436e3bd0d7120e7b24fc90a95a07fc1
sha256sums = ccac8a77ffe3c9421076aa3c94ffc1aa92bb4f60de4eec3aec6431446e01db9e
+ sha256sums = 84365baed4645a7cd0be1f97b896e3e0274eb1cbcfece1afbe9e41555fa1881c
pkgname = libuhd3
-
diff --git a/PKGBUILD b/PKGBUILD
index c99c2f47ad04..2384a084fe7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=libuhd3
pkgver=3.15.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Universal Software Radio Peripheral (USRP) userspace driver"
arch=('x86_64')
url="https://files.ettus.com/manual/"
@@ -18,10 +18,12 @@ conflicts=('libuhd>3.15.0.0' 'libuhd-firmware>3.15.0.0')
source=("libuhd-$pkgver.tar.gz::https://github.com/EttusResearch/uhd/archive/v$pkgver.tar.gz"
"boost-1.73.patch"
- "gcc-11.1.patch")
+ "gcc-11.1.patch"
+ "boost-1.76.patch")
sha256sums=('eed4a77d75faafff56be78985950039f8d9d1eb9fcbd58b8862e481dd49825cd'
'10c2f221dee97418f92d10606f9b9fea1436e3bd0d7120e7b24fc90a95a07fc1'
- 'ccac8a77ffe3c9421076aa3c94ffc1aa92bb4f60de4eec3aec6431446e01db9e')
+ 'ccac8a77ffe3c9421076aa3c94ffc1aa92bb4f60de4eec3aec6431446e01db9e'
+ '84365baed4645a7cd0be1f97b896e3e0274eb1cbcfece1afbe9e41555fa1881c')
prepare() {
cd "$srcdir/uhd-$pkgver"
@@ -33,6 +35,10 @@ prepare() {
# header dependency changes since GCC 11.1
# See https://gcc.gnu.org/gcc-11/porting_to.html
patch --forward --strip=1 --input "$srcdir/gcc-11.1.patch"
+
+ # Fix missing/misplaced include for boost::math::sign
+ # as emerge since Boost 1.76
+ patch --forward --strip=1 --input "$srcdir/boost-1.76.patch"
cd "$srcdir/uhd-$pkgver/host"
mkdir build
diff --git a/boost-1.76.patch b/boost-1.76.patch
new file mode 100644
index 000000000000..17b944d4afdb
--- /dev/null
+++ b/boost-1.76.patch
@@ -0,0 +1,46 @@
+Only in a/host: build
+diff -aur a/host/lib/usrp/cores/rx_dsp_core_3000.cpp b/host/lib/usrp/cores/rx_dsp_core_3000.cpp
+--- a/host/lib/usrp/cores/rx_dsp_core_3000.cpp 2021-06-12 07:17:40.663375708 +0200
++++ b/host/lib/usrp/cores/rx_dsp_core_3000.cpp 2021-06-12 07:06:01.870025559 +0200
+@@ -15,6 +15,7 @@
+ #include <boost/assign/list_of.hpp>
+ #include <boost/bind.hpp>
+ #include <boost/math/special_functions/round.hpp>
++#include <boost/math/special_functions/sign.hpp>
+ #include <boost/thread/thread.hpp> //thread sleep
+ #include <algorithm>
+ #include <cmath>
+diff -aur a/host/lib/usrp/cores/rx_frontend_core_3000.cpp b/host/lib/usrp/cores/rx_frontend_core_3000.cpp
+--- a/host/lib/usrp/cores/rx_frontend_core_3000.cpp 2020-01-01 05:21:49.000000000 +0100
++++ b/host/lib/usrp/cores/rx_frontend_core_3000.cpp 2021-06-12 07:04:52.246690548 +0200
+@@ -13,6 +13,7 @@
+ #include <boost/assign/list_of.hpp>
+ #include <boost/bind.hpp>
+ #include <boost/math/special_functions/round.hpp>
++#include <boost/math/special_functions/sign.hpp>
+
+ using namespace uhd;
+
+diff -aur a/host/lib/usrp/usrp2/usrp2_impl.cpp b/host/lib/usrp/usrp2/usrp2_impl.cpp
+--- a/host/lib/usrp/usrp2/usrp2_impl.cpp 2020-01-01 05:21:49.000000000 +0100
++++ b/host/lib/usrp/usrp2/usrp2_impl.cpp 2021-06-11 21:09:09.120100971 +0200
+@@ -835,6 +835,9 @@
+ }
+ }
+
++#include <boost/math/special_functions/round.hpp>
++#include <boost/math/special_functions/sign.hpp>
++
+ double usrp2_impl::set_tx_dsp_freq(
+ const std::string &mb,
+ const double freq_
+@@ -878,9 +881,6 @@
+ );
+ }
+
+-#include <boost/math/special_functions/round.hpp>
+-#include <boost/math/special_functions/sign.hpp>
+-
+ void usrp2_impl::update_clock_source(const std::string &mb, const std::string &source){
+ //NOTICE: U2_REG_MISC_CTRL_CLOCK is on the wb clock, and cannot be set from fifo_ctrl
+ //clock source ref 10mhz