summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Pillot2020-11-16 22:10:38 +0100
committerTom Pillot2020-11-16 22:10:38 +0100
commit33aa08581ff68b29965c832e0f8df985f78ecdd8 (patch)
treee5244a043efff14bde62218550c909a4113188d9
downloadaur-33aa08581ff68b29965c832e0f8df985f78ecdd8.tar.gz
add to AUR
-rw-r--r--.SRCINFO31
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD26
-rw-r--r--gopass-ui-bin.install22
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3ae910b8326
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = gopass-ui-bin
+ pkgdesc = Awesome UI for the gopass CLI – a password manager for your daily business
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/codecentric/gopass-ui
+ install = gopass-ui-bin.install
+ arch = x86_64
+ license = MIT
+ depends = c-ares
+ depends = ffmpeg
+ depends = gtk3
+ depends = http-parser
+ depends = libevent
+ depends = libvpx
+ depends = libxslt
+ depends = libxss
+ depends = minizip
+ depends = nss
+ depends = re2
+ depends = snappy
+ depends = libnotify
+ depends = libappindicator-gtk3
+ depends = gopass
+ provides = gopass-ui
+ source = https://github.com/codecentric/gopass-ui/releases/download/v0.7.0/gopass-ui-0.7.0.pacman
+ source = LICENSE
+ sha256sums = 207c8fc34fd1f5cf6fa5aad69ea4966dc3edc94f0da75da8f96c3be15e31d0ab
+ sha256sums = 21852b19d5c49c5d36f2c23cc60a299beeb94a64ec197dab5a57065fd73ecac3
+
+pkgname = gopass-ui-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..47318e726701
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 codecentric AG
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a26df941694c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Tom Pillot <tom dot pillot at pm dot me>
+pkgname=gopass-ui-bin
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Awesome UI for the gopass CLI – a password manager for your daily business"
+arch=('x86_64')
+url="https://github.com/codecentric/gopass-ui"
+license=('MIT')
+depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss'
+ 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk3' 'gopass')
+provides=('gopass-ui')
+install="${pkgname}.install"
+source=("https://github.com/codecentric/gopass-ui/releases/download/v${pkgver}/gopass-ui-${pkgver}.pacman" 'LICENSE')
+
+sha256sums=('207c8fc34fd1f5cf6fa5aad69ea4966dc3edc94f0da75da8f96c3be15e31d0ab'
+ '21852b19d5c49c5d36f2c23cc60a299beeb94a64ec197dab5a57065fd73ecac3')
+
+package() {
+ cd "$srcdir"
+
+ cp -R "${srcdir}/usr/" "${pkgdir}/usr/"
+ cp -R "${srcdir}/opt/" "${pkgdir}/opt/"
+
+ # License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/gopass-ui-bin.install b/gopass-ui-bin.install
new file mode 100644
index 000000000000..1bbd1d6a1d86
--- /dev/null
+++ b/gopass-ui-bin.install
@@ -0,0 +1,22 @@
+post_install() {
+ :
+#!/bin/bash
+
+# Link to the binary
+ln -sf '/opt/Gopass UI/gopass-ui' '/usr/bin/gopass-ui'
+
+# SUID chrome-sandbox for Electron 5+
+chmod 4755 '/opt/Gopass UI/chrome-sandbox' || true
+
+update-mime-database /usr/share/mime || true
+update-desktop-database /usr/share/applications || true
+
+}
+post_remove() {
+ :
+#!/bin/bash
+
+# Delete the link to the binary
+rm -f '/usr/bin/gopass-ui'
+
+}