summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Krebs2017-04-12 23:12:04 +0200
committerSebastian Krebs2017-04-12 23:12:04 +0200
commit33acb8d6f832d1cd9426bae57ff9254997bc093a (patch)
treebc0dce99c4c2af762394092b8778ba678702e325
downloadaur-33acb8d6f832d1cd9426bae57ff9254997bc093a.tar.gz
0.3.1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--LICENSE7
-rwxr-xr-xPKGBUILD21
4 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a99ee9e0091
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Apr 12 21:11:36 UTC 2017
+pkgbase = dephpend
+ pkgdesc = Detect flaws in your architecture, before they drag you down into the depths of dependency hell ...
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://dephpend.com/
+ arch = any
+ license = MIT
+ depends = php
+ source = https://phar.dephpend.com/dephpend-0.3.1.phar
+ source = https://raw.githubusercontent.com/mihaeu/dephpend/0.3.1/LICENSE
+ sha256sums = 08be1f0fe7c6de19c3df89b2203d1e5c83c520302002d95fd2013d76e6d2f683
+ sha256sums = 2025717a285cf18f45e9a41ea41971b56f5a1692ce5ee03bb6c862514aadc97d
+
+pkgname = dephpend
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ed345a94681b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.xz
+src/
+pkg/
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..27a724e56da2
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,7 @@
+Copyright (c) 2016 Michael Haeuslmann <haeuslmann@gmail.com>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..ff58559dfdae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Sebastian Krebs <sebastian[at]krebs[dot]one>
+
+pkgname=dephpend
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Detect flaws in your architecture, before they drag you down into the depths of dependency hell ..."
+arch=('any')
+url="https://dephpend.com/"
+license=('MIT')
+depends=('php')
+source=("https://phar.dephpend.com/${pkgname}-${pkgver}.phar"
+ "https://raw.githubusercontent.com/mihaeu/${pkgname}/${pkgver}/LICENSE")
+sha256sums=('08be1f0fe7c6de19c3df89b2203d1e5c83c520302002d95fd2013d76e6d2f683'
+ '2025717a285cf18f45e9a41ea41971b56f5a1692ce5ee03bb6c862514aadc97d')
+
+package() {
+ install -D -m 644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m 755 "${srcdir}/${pkgname}-${pkgver}.phar" "${pkgdir}/usr/share/webapps/bin/${pkgname}.phar"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/webapps/bin/${pkgname}.phar" "${pkgdir}/usr/bin/${pkgname}"
+}