summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Auditor2016-02-03 17:32:48 +0100
committerStefan Auditor2016-02-03 17:32:48 +0100
commit33e6c5ee2c623abc2ba28fa1d225effbb6ad83c5 (patch)
tree18822197ca8aa6cea4899274fdbfe286440c877e
downloadaur-33e6c5ee2c623abc2ba28fa1d225effbb6ad83c5.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5bf773c8ab67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Feb 3 16:11:58 UTC 2016
+pkgbase = phpqa
+ pkgdesc = PHPQA all-in-one Analyzer CLI tool.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/jmolivas/phpqa
+ arch = any
+ license = MIT
+ makedepends = php-box
+ makedepends = php-composer
+ makedepends = git
+ depends = php
+ source = phpqa::git+https://github.com/jmolivas/phpqa.git
+ sha512sums = SKIP
+
+pkgname = phpqa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2396817a9136
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Stefan Auditor <stefan.auditor@erdfisch.de>
+
+_pkgname=phpqa
+pkgname=${_pkgname}
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="PHPQA all-in-one Analyzer CLI tool."
+arch=("any")
+url="https://github.com/jmolivas/phpqa"
+license=("MIT")
+depends=("php")
+makedepends=("php-box" "php-composer" "git")
+source=("${_pkgname}"::"git+https://github.com/jmolivas/phpqa.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --abbrev=0 --tags
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ php /usr/bin/composer install --no-dev
+}
+
+package() {
+ cd "${srcdir}"
+ install -d "${pkgdir}/usr/share/webapps/${_pkgname}"
+ cp -r "${_pkgname}" "${pkgdir}/usr/share/webapps/"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "${pkgdir}/usr/share/webapps/${_pkgname}/bin/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}