summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2021-07-12 13:53:45 +0200
committerXiretza2021-07-12 13:53:45 +0200
commit3408cab97749a1801396e777301ec53835bec8c5 (patch)
treebd409f1de80a70b4d19f0b55ce73a0410ce884ca
downloadaur-3408cab97749a1801396e777301ec53835bec8c5.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2d3329d679d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pyattributes
+ pkgdesc = Implementations of .NET-like attributes realized with Python decorators
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/Paebbels/pyAttributes
+ arch = any
+ license = Apache
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python-argcomplete
+ source = python-pyattributes-2.1.0.tar.gz::https://github.com/Paebbels/pyAttributes/archive/v2.1.0.tar.gz
+ sha256sums = ab4b3cef5f4dc2d74ad935594c317300197fb462eab55710a7f1bbfc004396a7
+
+pkgname = python-pyattributes
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ba60466783e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: xiretza <xiretza+aur@xiretza.xyz>
+
+_pkgname='pyAttributes'
+pkgname=python-${_pkgname,,}
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Implementations of .NET-like attributes realized with Python decorators"
+arch=(any)
+url="https://github.com/Paebbels/pyAttributes"
+license=('Apache')
+depends=('python-argcomplete')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('ab4b3cef5f4dc2d74ad935594c317300197fb462eab55710a7f1bbfc004396a7')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+check(){
+ cd "$_pkgname-$pkgver"
+ touch tests/__init__.py
+ pytest --override-ini 'python_files=*' tests/
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}