summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryparitcher2020-06-05 14:10:09 -0400
committeryparitcher2020-06-05 14:10:09 -0400
commit340d24433e419cdbe2d16c32c174b8c9e3e22955 (patch)
tree1a5997263eb16b43b677eecaf3b6443969c7261b
parentc06adfa86891359fc4e82f17f4e207da16655e50 (diff)
downloadaur-340d24433e419cdbe2d16c32c174b8c9e3e22955.tar.gz
remove unneeded patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--cpp11.diff14
3 files changed, 6 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1cc6d2fed41a..86c98d7c5400 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xxdiff
pkgdesc = A graphical browser for file and directory differences.
pkgver = 5.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/blais/xxdiff
arch = x86_64
arch = i686
@@ -11,10 +11,8 @@ pkgbase = xxdiff
makedepends = git
makedepends = python-docutils
depends = qt5-base
- source = git+https://github.com/blais/xxdiff.git
- source = cpp11.diff
+ source = git+https://github.com/blais/xxdiff.git#commit=30b44034e5cc2665f7fc44ce45da7252d46cbe17
md5sums = SKIP
- md5sums = feb486afc64fa53cfc348219d3779d41
pkgname = xxdiff
diff --git a/PKGBUILD b/PKGBUILD
index 2714697310b6..d61b56dbbd39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,16 @@
pkgname=xxdiff
pkgver=5.0
-pkgrel=2
+pkgrel=3
pkgdesc="A graphical browser for file and directory differences."
url="https://github.com/blais/xxdiff"
license=('GPL2')
depends=('qt5-base')
makedepends=('flex>=2.5.31' 'bison' 'git' 'python-docutils')
arch=('x86_64' 'i686')
-source=("git+https://github.com/blais/xxdiff.git" "cpp11.diff")
-md5sums=('SKIP'
- 'feb486afc64fa53cfc348219d3779d41')
-
-prepare() {
- cd "xxdiff/src"
- # Debian C++11 Patch
- patch -N -i ../../cpp11.diff
-}
+_commit=30b44034e5cc2665f7fc44ce45da7252d46cbe17
+source=("git+https://github.com/blais/xxdiff.git#commit=$_commit")
+md5sums=('SKIP')
build() {
cd "$pkgname/src"
diff --git a/cpp11.diff b/cpp11.diff
deleted file mode 100644
index 3daea408f126..000000000000
--- a/cpp11.diff
+++ /dev/null
@@ -1,14 +0,0 @@
-Description: building against Qt5 requires at least C++11
-Author: Florian Schlichting <fsfs@debian.org>
-
---- a/src/xxdiff.pro
-+++ b/src/xxdiff.pro
-@@ -111,7 +111,7 @@
- #linux-g++:QMAKE_LIBS += -lmpatrol -lbfd -liberty
-
- # auto_ptr deprecated in C++11, removed in C++17
--linux: QMAKE_CXXFLAGS += -std=c++03
-+linux: QMAKE_CXXFLAGS += -std=c++11
-
- #----------------------------------------
- # Max OS X with XFree86 port, macx-g++