summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-08-17 11:38:30 -0600
committerMark Wagie2021-08-17 11:38:30 -0600
commit3418d7d805b0d9808fe49d7c1dea08cb31b8acd9 (patch)
treed49f6098548f3206f789d81dd0fc5a05ce28e054
parent62c28da2e0406270a5ffca22a7606136e2762b56 (diff)
downloadaur-3418d7d805b0d9808fe49d7c1dea08cb31b8acd9.tar.gz
Partial support for GNOME 40
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD47
2 files changed, 32 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ec664e3704d..aa5152f64714 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-multi-monitors-add-on-git
pkgdesc = Adds panels and thumbnails for additional monitors.
- pkgver = 20.r5.gb883e19
- pkgrel = 1
+ pkgver = 23.r0.g0cec99d
+ pkgrel = 2
url = https://github.com/spin83/multi-monitors-add-on
arch = any
license = GPL2
@@ -10,7 +10,8 @@ pkgbase = gnome-shell-extension-multi-monitors-add-on-git
provides = gnome-shell-extension-multi-monitors-add-on
conflicts = gnome-shell-extension-multi-monitors-add-on
source = git+https://github.com/spin83/multi-monitors-add-on.git
+ source = https://github.com/spin83/multi-monitors-add-on/pull/159.patch
sha256sums = SKIP
+ sha256sums = e9f7f7c71c52fa88b7a231804e2bc877bff6799c65b339d7f818c921d1b3a354
pkgname = gnome-shell-extension-multi-monitors-add-on-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 269019e4dd18..72c364ec506d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: smcdougall <simon at sjmcdougall dot com>
pkgname=gnome-shell-extension-multi-monitors-add-on-git
_pkgname=multi-monitors-add-on
-pkgver=20.r5.gb883e19
-pkgrel=1
+pkgver=23.r0.g0cec99d
+pkgrel=2
pkgdesc="Adds panels and thumbnails for additional monitors."
arch=('any')
url="https://github.com/spin83/multi-monitors-add-on"
@@ -13,31 +13,40 @@ depends=('gnome-shell')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/spin83/multi-monitors-add-on.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/spin83/multi-monitors-add-on.git'\
+ 'https://github.com/spin83/multi-monitors-add-on/pull/159.patch')
+sha256sums=('SKIP'
+ 'e9f7f7c71c52fa88b7a231804e2bc877bff6799c65b339d7f818c921d1b3a354')
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
- _uuid="$_pkgname@spin83"
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ # Partial support for GNOME 40
+ patch -Np1 -i $srcdir/159.patch
+}
- cd "$srcdir/$_pkgname/$_uuid"
- install -Dm644 schemas/*.xml -t "$pkgdir/usr/share/glib-2.0/schemas"
+package() {
+ _uuid="$_pkgname@spin83"
- # Extension does not detect icons here
-# install -Dm644 icons/*.svg -t "$pkgdir/usr/share/icons/hicolor/symbolic/apps"
+ cd "$srcdir/$_pkgname"
- for locale in locale/*/; do
- install -Dm644 -t "$pkgdir/usr/share/${locale}/LC_MESSAGES" \
- "${locale}/LC_MESSAGES"/*.mo
- done
+ for locale in "$_uuid"/locale/*/; do
+ install -Dm644 -t "$pkgdir/usr/share/${locale}/LC_MESSAGES" \
+ "${locale}/LC_MESSAGES"/*.mo
+ done
- rm -rf locale
+ install -d "$pkgdir/usr/share/gnome-shell/extensions"
+ cp -a "$_uuid" "$pkgdir/usr/share/gnome-shell/extensions"
+ rm -rf "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/locale"
+ rm "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/$_pkgname.pot"
- install -d "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
- cp -a * "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+ install -d "$pkgdir/usr/share/glib-2.0/schemas"
+ ln -s "/usr/share/gnome-shell/extensions/$_uuid/schemas/org.gnome.shell.extensions.$_pkgname.gschema.xml" \
+ "$pkgdir/usr/share/glib-2.0/schemas"
}