summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2019-08-04 20:04:13 -0400
committerChris Severance2019-08-04 20:04:13 -0400
commit34268cddb330acf2e50bffb61c39359d47e957b6 (patch)
treea8dcb57e11889f9db68db4a9a151b872f9245e91
parent851aaf9434d1d60ee25785f928f8bb7578f30563 (diff)
downloadaur-34268cddb330acf2e50bffb61c39359d47e957b6.tar.gz
autu: Update to 2.2.2-1 sysmacros patch
-rw-r--r--.SRCINFO10
-rw-r--r--0000-sysmacros.patch10
-rw-r--r--PKGBUILD31
3 files changed, 38 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7336ac4cb8fe..9974938322a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
# Generated by mksrcinfo v8
-# Tue Jan 16 06:43:57 UTC 2018
+# Mon Aug 5 00:04:13 UTC 2019
pkgbase = wipefreespace
- pkgdesc = Securely wipe the free space on an ext2/3/4,NTFS, XFS,ReiserFSv3, ReiserFSv4, FAT12/16/32,Minix,JFS and HFS+ partition or drive
+ pkgdesc = Securely wipe the free space on an ext2/3/4,NTFS, XFS, ReiserFSv3, ReiserFSv4, FAT12/16/32, Minix, JFS and HFS+ partition or drive
pkgver = 2.2.2
pkgrel = 1
- url = https://wipefreespace.sourceforge.net/
+ url = https://sourceforge.net/projects/wipefreespace
arch = i686
arch = x86_64
license = GPL
source = https://downloads.sourceforge.net/project/wipefreespace/wipefreespace/2.2.2/wipefreespace-2.2.2.tar.gz
+ source = 0000-sysmacros.patch
+ md5sums = c5b97fc173e1b33dab63bd66b705ceca
+ md5sums = fb1e4e01526cdfa3f853e2b2b99b71f1
sha256sums = 31e372e0150adaec923713ab22eabdc27b10690b89443cfe4dba37d7dedf5d32
+ sha256sums = 500c4e1fa566be22e3b07e1bcf0a36b0f18d8f46ac9922e603e1a42edb2b7902
pkgname = wipefreespace
diff --git a/0000-sysmacros.patch b/0000-sysmacros.patch
new file mode 100644
index 000000000000..c4dd4be01fd9
--- /dev/null
+++ b/0000-sysmacros.patch
@@ -0,0 +1,10 @@
+--- src/wfs_util.c.orig 2018-01-02 15:27:53.000000000 -0500
++++ src/wfs_util.c 2019-08-04 19:53:05.301455493 -0400
+@@ -123,6 +123,7 @@
+ #ifdef HAVE_SYS_TYPES_H
+ # include <sys/types.h> /* for open() */
+ #endif
++#include <sys/sysmacros.h>
+
+ #ifdef HAVE_SYS_STAT_H
+ # include <sys/stat.h>
diff --git a/PKGBUILD b/PKGBUILD
index bbdea4797e3f..e0a61033c607 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,28 +5,39 @@ set -u
pkgname='wipefreespace'
pkgver='2.2.2'
pkgrel='1'
-pkgdesc='Securely wipe the free space on an ext2/3/4,NTFS, XFS,ReiserFSv3, ReiserFSv4, FAT12/16/32,Minix,JFS and HFS+ partition or drive'
+pkgdesc='Securely wipe the free space on an ext2/3/4,NTFS, XFS, ReiserFSv3, ReiserFSv4, FAT12/16/32, Minix, JFS and HFS+ partition or drive'
arch=('i686' 'x86_64')
-url='https://wipefreespace.sourceforge.net/'
+url='https://sourceforge.net/projects/wipefreespace'
license=('GPL')
-_verwatch=('https://sourceforge.net/projects/wipefreespace/rss' ".*<title>.*/${pkgname}-\([0-9\.]\+\)\.tar\.gz\].*" 'f')
-source=("https://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('31e372e0150adaec923713ab22eabdc27b10690b89443cfe4dba37d7dedf5d32')
+_verwatch=("${url}/rss" ".*<title>.*/${pkgname}-\([0-9\.]\+\)\.tar\.gz\].*" 'f')
+source=(
+ "https://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ '0000-sysmacros.patch'
+)
+md5sums=('c5b97fc173e1b33dab63bd66b705ceca'
+ 'fb1e4e01526cdfa3f853e2b2b99b71f1')
+sha256sums=('31e372e0150adaec923713ab22eabdc27b10690b89443cfe4dba37d7dedf5d32'
+ '500c4e1fa566be22e3b07e1bcf0a36b0f18d8f46ac9922e603e1a42edb2b7902')
prepare() {
set -u
cd "${pkgbase}-${pkgver}"
- CFLAGS="${CFLAGS} -Wno-unused-result" \
- ./configure --prefix='/usr'
- echo '#define HAVE_LINUX_LOOP_H 1' >> 'config.h'
+
+ # diff -pNau3 src/wfs_util.c{.orig,} > '0000-sysmacros.patch'
+ patch -Nbup0 -i "${srcdir}/0000-sysmacros.patch"
+
set +u
}
build() {
set -u
cd "${pkgbase}-${pkgver}"
- local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
- nice make -s -j "${_nproc}"
+ if [ ! -s 'Makefile' ]; then
+ CFLAGS="${CFLAGS} -Wno-unused-result" \
+ ./configure --prefix='/usr'
+ echo '#define HAVE_LINUX_LOOP_H 1' >> 'config.h'
+ fi
+ make -s
set +u
}