summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 21:54:19 +0100
committerBartłomiej Piotrowski2018-01-06 21:54:19 +0100
commit3446c635b7cab509efa1d3456776e1a58fef4685 (patch)
treee1d41edece5c059a9bcaa504db0a2c1e3f32d0a7
downloadaur-3446c635b7cab509efa1d3456776e1a58fef4685.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD54
-rw-r--r--gq-1.3.4-configure.patch13
-rw-r--r--gq-1.3.4-dso.patch12
-rw-r--r--gq-1.3.4-errorchain.patch47
-rw-r--r--gq-1.3.4-glibfix.patch112
-rw-r--r--gq-1.3.4-kerberos.patch11
-rw-r--r--gq-1.3.4-sanity-check.patch19
-rw-r--r--gq-1.3.4-strcmp-null-safe.patch13
9 files changed, 318 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3056f702ee0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = gq
+ pkgdesc = interactive graphical LDAP browser
+ pkgver = 1.3.4
+ pkgrel = 8
+ url = https://sourceforge.net/projects/gqclient/
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = pkgconfig
+ makedepends = gnome-doc-utils
+ depends = libxml2
+ depends = openssl-1.0
+ depends = gtk2
+ depends = libgnome-keyring
+ depends = libglade
+ depends = libldap>=2.4.18
+ depends = libgpg-error
+ depends = libgcrypt
+ source = https://downloads.sourceforge.net/sourceforge/gqclient/gq-1.3.4.tar.gz
+ source = gq-1.3.4-kerberos.patch
+ source = gq-1.3.4-configure.patch
+ source = gq-1.3.4-dso.patch
+ source = gq-1.3.4-glibfix.patch
+ source = gq-1.3.4-errorchain.patch
+ source = gq-1.3.4-strcmp-null-safe.patch
+ source = gq-1.3.4-sanity-check.patch
+ sha256sums = 2ac77f3233ddaef718f89c9371ab5165af29cf9738ed46b6bea64b37e45d4b60
+ sha256sums = bc985d3a59ff08747a58c53112cc2903b0cba438ee3b328b9bbf4976226c5402
+ sha256sums = a3ba1a50c19469834170632d6f5289cada81f04b7921fb16c37327a5f946f770
+ sha256sums = 7b7a39eafaff8b4ffe34b263330a6eb0b20827c51deaff83e80dbce6460b6e50
+ sha256sums = ce2b395da210fd5f68d2afb80de2d15f77d4161fbb9911fe876d891cf21cf057
+ sha256sums = 983d2ca845306d76b2fe4167eb1f479f3ee2ad81f3318602be9e99ab117689e6
+ sha256sums = 396098fe4b4550c3260c97fe4de209088860e1fe3acf6aaa9574b67a4d9b85b8
+ sha256sums = 1c65f6ecb1fedb1a06f3c52f48d0dc8456c386e86ef5a629fc4ddfc1259ec613
+
+pkgname = gq
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aee209aa72df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Gergely Tamas <dice@mfa.kfki.hu>
+
+pkgname=gq
+pkgver=1.3.4
+pkgrel=8
+pkgdesc="interactive graphical LDAP browser"
+url="https://sourceforge.net/projects/gqclient/"
+license=("GPL")
+depends=('libxml2' 'openssl-1.0' 'gtk2' 'libgnome-keyring' 'libglade' 'libldap>=2.4.18' 'libgpg-error' 'libgcrypt')
+makedepends=('intltool' 'pkgconfig' 'gnome-doc-utils')
+arch=('x86_64')
+source=(https://downloads.sourceforge.net/sourceforge/gqclient/$pkgname-$pkgver.tar.gz
+ gq-1.3.4-kerberos.patch
+ gq-1.3.4-configure.patch
+ gq-1.3.4-dso.patch
+ gq-1.3.4-glibfix.patch
+ gq-1.3.4-errorchain.patch
+ gq-1.3.4-strcmp-null-safe.patch
+ gq-1.3.4-sanity-check.patch)
+sha256sums=('2ac77f3233ddaef718f89c9371ab5165af29cf9738ed46b6bea64b37e45d4b60'
+ 'bc985d3a59ff08747a58c53112cc2903b0cba438ee3b328b9bbf4976226c5402'
+ 'a3ba1a50c19469834170632d6f5289cada81f04b7921fb16c37327a5f946f770'
+ '7b7a39eafaff8b4ffe34b263330a6eb0b20827c51deaff83e80dbce6460b6e50'
+ 'ce2b395da210fd5f68d2afb80de2d15f77d4161fbb9911fe876d891cf21cf057'
+ '983d2ca845306d76b2fe4167eb1f479f3ee2ad81f3318602be9e99ab117689e6'
+ '396098fe4b4550c3260c97fe4de209088860e1fe3acf6aaa9574b67a4d9b85b8'
+ '1c65f6ecb1fedb1a06f3c52f48d0dc8456c386e86ef5a629fc4ddfc1259ec613')
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 -i ../gq-1.3.4-kerberos.patch
+ patch -Np0 -i ../gq-1.3.4-configure.patch
+ patch -Np1 -i ../gq-1.3.4-dso.patch
+ patch -Np1 -i ../gq-1.3.4-glibfix.patch
+ patch -Np1 -i ../gq-1.3.4-errorchain.patch
+ patch -Np1 -i ../gq-1.3.4-strcmp-null-safe.patch
+ patch -Np1 -i ../gq-1.3.4-sanity-check.patch
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig \
+ CFLAGS+=" -I/usr/include/openssl-1.0" \
+ LDFLAGS+="-I/usr/lib/openssl-1.0" \
+ ./configure --prefix=/usr --disable-debugging --disable-update-mimedb
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
diff --git a/gq-1.3.4-configure.patch b/gq-1.3.4-configure.patch
new file mode 100644
index 000000000000..903b08c491d0
--- /dev/null
+++ b/gq-1.3.4-configure.patch
@@ -0,0 +1,13 @@
+--- configure~ 2008-02-13 22:14:37.000000000 +0100
++++ configure 2009-11-06 10:28:57.000000000 +0100
+@@ -6608,8 +6608,9 @@
+
+ # Check whether --with-kerberos-prefix was given.
+ if test "${with_kerberos_prefix+set}" = set; then
++ KRB5_LIBS="`$with_kerberos_prefix/bin/krb5-config --libs`"
+ withval=$with_kerberos_prefix;
+- LIBS="-L$with_kerberos_prefix/lib -lkrb5 -ldes425 $LIBS"
++ LIBS="-L$with_kerberos_prefix/lib $KRB5_LIBS $LIBS"
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_KERBEROS 1
diff --git a/gq-1.3.4-dso.patch b/gq-1.3.4-dso.patch
new file mode 100644
index 000000000000..0f23d52410da
--- /dev/null
+++ b/gq-1.3.4-dso.patch
@@ -0,0 +1,12 @@
+diff -up gq-1.3.4/configure~ gq-1.3.4/configure
+--- gq-1.3.4/configure~ 2010-02-11 22:47:33.000000000 +0100
++++ gq-1.3.4/configure 2010-02-11 22:49:41.189235801 +0100
+@@ -6494,7 +6494,7 @@ fi
+ { echo "$as_me:$LINENO: result: $ac_cv_lib_ssl_SSL_new" >&5
+ echo "${ECHO_T}$ac_cv_lib_ssl_SSL_new" >&6; }
+ if test $ac_cv_lib_ssl_SSL_new = yes; then
+- LIBS="-lssl $LIBS"
++ LIBS="`pkg-config --libs openssl` $LIBS"
+
+ fi
+
diff --git a/gq-1.3.4-errorchain.patch b/gq-1.3.4-errorchain.patch
new file mode 100644
index 000000000000..fcacdd2ff1e8
--- /dev/null
+++ b/gq-1.3.4-errorchain.patch
@@ -0,0 +1,47 @@
+commit 58ce4cd00705dd15ba2f509a00c0c58490489f32
+Author: Terje Røsten <terje.rosten@ntnu.no>
+Date: Mon Nov 18 20:41:36 2013 +0100
+
+ fix too creative hackery
+
+diff --git a/src/errorchain.c b/src/errorchain.c
+index fc3092d..84dae81 100644
+--- a/src/errorchain.c
++++ b/src/errorchain.c
+@@ -110,34 +110,13 @@ error_push_production_v(int context,
+ {
+ struct errchain *chain;
+ GString *str;
+- int n, a, retry = 0;
+
+ if(!context) {
+ return;
+ }
+
+- a = strlen(fmt) + 50;
+- str = g_string_sized_new(a);
+-#warning "FIXME: this is so sick"
+-
+- /* I hope it is ok to repeatedly use ap like this */
+- do {
+- n = g_vsnprintf(str->str, a - 1, fmt, ap);
+-
+- retry = 0;
+- /* await both n==-1 and n > a -1 for not enough free space */
+- if (n > a - 1) {
+- g_string_free(str, TRUE);
+- a = n + 2;
+- str = g_string_sized_new(a);
+- retry = 1;
+- } else if (n == -1) {
+- g_string_free(str, TRUE);
+- a *= 2;
+- str = g_string_sized_new(a);
+- retry = 1;
+- }
+- } while (retry);
++ str = g_string_sized_new(100);
++ g_string_vprintf(str, fmt, ap);
+
+ /* plug into messagechain */
+ chain = error_chain_by_context(context);
diff --git a/gq-1.3.4-glibfix.patch b/gq-1.3.4-glibfix.patch
new file mode 100644
index 000000000000..435d23774f8f
--- /dev/null
+++ b/gq-1.3.4-glibfix.patch
@@ -0,0 +1,112 @@
+diff -up gq-1.3.4/src/glib-helpers.c.glibfix gq-1.3.4/src/glib-helpers.c
+--- gq-1.3.4/src/glib-helpers.c.glibfix 2012-03-21 11:55:37.537889970 -0400
++++ gq-1.3.4/src/glib-helpers.c 2012-03-21 11:55:44.886831913 -0400
+@@ -23,8 +23,7 @@
+
+ #include "glib-helpers.h"
+
+-#include <glib/gmessages.h>
+-#include <glib/gunicode.h>
++#include <glib.h>
+
+ GList*
+ g_list_copy_reversed(GList* list) {
+diff -up gq-1.3.4/src/glib-helpers.h.glibfix gq-1.3.4/src/glib-helpers.h
+--- gq-1.3.4/src/glib-helpers.h.glibfix 2012-03-21 11:55:23.107003954 -0400
++++ gq-1.3.4/src/glib-helpers.h 2012-03-21 11:55:30.301947128 -0400
+@@ -24,7 +24,7 @@
+ #ifndef GLIB_HELPERS_H
+ #define GLIB_HELPERS_H
+
+-#include <glib/glist.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
+diff -up gq-1.3.4/src/gq-hash.h.glibfix gq-1.3.4/src/gq-hash.h
+--- gq-1.3.4/src/gq-hash.h.glibfix 2012-03-21 11:53:31.510895451 -0400
++++ gq-1.3.4/src/gq-hash.h 2012-03-21 11:53:36.386856283 -0400
+@@ -24,7 +24,7 @@
+ #ifndef GQ_ENCRYPTION_H
+ #define GQ_ENCRYPTION_H
+
+-#include <glib/garray.h>
++#include <glib.h>
+ #include "gq-utilities.h"
+
+ G_BEGIN_DECLS
+diff -up gq-1.3.4/src/gq-main-loop.h.glibfix gq-1.3.4/src/gq-main-loop.h
+--- gq-1.3.4/src/gq-main-loop.h.glibfix 2012-03-21 11:53:47.392767870 -0400
++++ gq-1.3.4/src/gq-main-loop.h 2012-03-21 11:53:55.688701227 -0400
+@@ -24,7 +24,7 @@
+ #ifndef GQ_MAIN_LOOP_H
+ #define GQ_MAIN_LOOP_H
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
+diff -up gq-1.3.4/src/gq-stack.c.glibfix gq-1.3.4/src/gq-stack.c
+--- gq-1.3.4/src/gq-stack.c.glibfix 2012-03-21 11:54:25.894458573 -0400
++++ gq-1.3.4/src/gq-stack.c 2012-03-21 11:54:34.673388048 -0400
+@@ -23,9 +23,7 @@
+
+ #include "gq-stack.h"
+
+-#include <glib/gmem.h>
+-#include <glib/gmessages.h>
+-#include <glib/glist.h>
++#include <glib.h>
+
+ #undef DEBUG_STACK
+
+diff -up gq-1.3.4/src/gq-stack.h.glibfix gq-1.3.4/src/gq-stack.h
+--- gq-1.3.4/src/gq-stack.h.glibfix 2012-03-21 11:54:43.597316357 -0400
++++ gq-1.3.4/src/gq-stack.h 2012-03-21 11:54:48.001281125 -0400
+@@ -24,7 +24,7 @@
+ #ifndef GQ_STACK_H
+ #define GQ_STACK_H
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
+diff -up gq-1.3.4/src/gq-tab.h.glibfix gq-1.3.4/src/gq-tab.h
+--- gq-1.3.4/src/gq-tab.h.glibfix 2012-03-21 11:51:51.367699882 -0400
++++ gq-1.3.4/src/gq-tab.h 2012-03-21 11:52:23.572441194 -0400
+@@ -24,7 +24,7 @@
+ #ifndef GQ_TAB_H
+ #define GQ_TAB_H
+
+-#include <glib/gmacros.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
+diff -up gq-1.3.4/src/state.c.glibfix gq-1.3.4/src/state.c
+--- gq-1.3.4/src/state.c.glibfix 2012-03-21 11:56:07.083656517 -0400
++++ gq-1.3.4/src/state.c 2012-03-21 11:57:22.728058334 -0400
+@@ -35,8 +35,8 @@
+ #include <fcntl.h>
+ #include <errno.h>
+
++#include <glib.h>
+ #include <glib/gi18n.h>
+-#include <glib/gmessages.h>
+ #include <gtk/gtk.h>
+
+ #include "configfile.h"
+diff -up gq-1.3.4/src/syntax.h.glibfix gq-1.3.4/src/syntax.h
+--- gq-1.3.4/src/syntax.h.glibfix 2012-03-21 11:54:05.200624814 -0400
++++ gq-1.3.4/src/syntax.h 2012-03-21 11:54:12.706564518 -0400
+@@ -27,7 +27,7 @@
+ #ifndef GQ_SYNTAX_H_INCLUDED
+ #define GQ_SYNTAX_H_INCLUDED
+
+-#include <glib/gmacros.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
diff --git a/gq-1.3.4-kerberos.patch b/gq-1.3.4-kerberos.patch
new file mode 100644
index 000000000000..b48b8d5af234
--- /dev/null
+++ b/gq-1.3.4-kerberos.patch
@@ -0,0 +1,11 @@
+--- gq-1.3.4/src/gq-server.c~ 2008-01-09 17:35:12.000000000 +0100
++++ gq-1.3.4/src/gq-server.c 2009-11-05 18:41:28.000000000 +0100
+@@ -281,7 +281,7 @@
+ switch(gq_server_get_bind_type(server)) {
+ case GQ_BIND_KERBEROS:
+ #ifdef HAVE_KERBEROS
+- rc = ldap_bind_s(ld, bind_dn, bindpw, LDAP_AUTH_KRBV4);
++ rc = ldap_bind_s(ld, bind_dn, bind_pw, LDAP_AUTH_KRBV4);
+ #else
+ error_push(open_context,
+ _("Cannot use Kerberos bind with '%s'.\n"
diff --git a/gq-1.3.4-sanity-check.patch b/gq-1.3.4-sanity-check.patch
new file mode 100644
index 000000000000..32596603432a
--- /dev/null
+++ b/gq-1.3.4-sanity-check.patch
@@ -0,0 +1,19 @@
+commit 06582f488aab4b01670aba709485e021766659a1
+Author: Terje Røsten <terje.rosten@ntnu.no>
+Date: Thu Nov 21 20:17:04 2013 +0100
+
+ Sanity check
+
+diff --git a/src/gq-browser-model.c b/src/gq-browser-model.c
+index ee66a45..ee5fa09 100644
+--- a/src/gq-browser-model.c
++++ b/src/gq-browser-model.c
+@@ -183,7 +183,7 @@ gq_browser_model_validate(gconstpointer * model,
+ g_print("browser_model_validate_iter(%p, %p): ", model, iter);
+ #endif
+ #warning "FIXME: check stamp"
+- if(!iter->user_data) {
++ if(!iter || !iter->user_data) {
+ #ifdef DEBUG_MODEL
+ g_print("false (iter->user_data == NULL)\n");
+ #endif
diff --git a/gq-1.3.4-strcmp-null-safe.patch b/gq-1.3.4-strcmp-null-safe.patch
new file mode 100644
index 000000000000..60b010d74ac4
--- /dev/null
+++ b/gq-1.3.4-strcmp-null-safe.patch
@@ -0,0 +1,13 @@
+diff --git a/src/gq-input-form.c b/src/gq-input-form.c
+index a73dc9b..0e15a0c 100644
+--- a/src/gq-input-form.c
++++ b/src/gq-input-form.c
+@@ -952,7 +952,7 @@ dn_changed(GtkEditable *editable,
+ if(P(iform)->button_add_new) {
+ gchar * val = gtk_editable_get_chars(editable, 0, -1);
+ gchar const* dn = gq_input_form_get_dn(iform);
+- gtk_widget_set_sensitive(P(iform)->button_add_new, strcmp(dn, val) != 0);
++ gtk_widget_set_sensitive(P(iform)->button_add_new, g_strcmp0(dn, val) != 0);
+ g_free(val);
+ }
+ }