summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2020-12-23 13:30:09 +0600
committerMubashshir2020-12-23 13:30:09 +0600
commit34569ee2280ad68191f456eda5ba11af2c5875fd (patch)
treefaac9009162125a9d4216527f6986d6a79c531de
parenta5da3925027a366ca2802845e01b3216a5f50e96 (diff)
downloadaur-34569ee2280ad68191f456eda5ba11af2c5875fd.tar.gz
pkgrel bump
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD9
-rw-r--r--apkstudio.install14
4 files changed, 28 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87f7e7a649f1..59b6e227a588 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = apkstudio-git
pkgdesc = An IDE for decompiling/editing & then recompiling of android application binaries.
pkgver = r299.71ca9b5
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = http://www.vaibhavpandey.com/apkstudio/
+ install = apkstudio.install
arch = i686
arch = x86_64
license = GPL2
@@ -11,7 +12,10 @@ pkgbase = apkstudio-git
makedepends = qt5-tools
makedepends = unzip
depends = qt5-base
- depends = android-tools
+ depends = adb
+ depends = jadx
+ depends = uber-apk-signer-bin
+ depends = android-apktool
source = git+https://github.com/vaibhavpandeyvpz/apkstudio.git
source = git+https://github.com/Dax89/QHexView.git
source = git+https://github.com/Jorgen-VikingGod/Qt-Frameless-Window-DarkStyle
diff --git a/.gitignore b/.gitignore
index e4f9ba3007cf..df32f2353c82 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.SRCINFO
!PKGBUILD
!.gitignore
+!apkstudio.install
diff --git a/PKGBUILD b/PKGBUILD
index 1785bd96d1b2..610f3a09b6f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,23 @@
_pkgname=apkstudio
pkgname=$_pkgname-git
pkgver=r299.71ca9b5
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='An IDE for decompiling/editing & then recompiling of android application binaries.'
arch=('i686' 'x86_64')
url='http://www.vaibhavpandey.com/apkstudio/'
license=('GPL2')
-depends=('qt5-base' 'android-tools')
+depends=('qt5-base'
+ 'adb'
+ 'jadx'
+ 'uber-apk-signer-bin'
+ 'android-apktool')
makedepends=('git' 'qt5-tools' 'unzip')
source=('git+https://github.com/vaibhavpandeyvpz/apkstudio.git'
'git+https://github.com/Dax89/QHexView.git'
'git+https://github.com/Jorgen-VikingGod/Qt-Frameless-Window-DarkStyle')
sha256sums=('SKIP' 'SKIP' 'SKIP')
+install=apkstudio.install
pkgver() {
cd "$srcdir/$_pkgname"
diff --git a/apkstudio.install b/apkstudio.install
new file mode 100644
index 000000000000..b6c8e0a7f75c
--- /dev/null
+++ b/apkstudio.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo "After launching apkstudio, set 3rd party binary paths as shown below:"
+ cat <<EOF
+
+ Apktool:
+ /usr/share/android-apktool/apktool.jar
+
+ Jadx:
+ /usr/bin/jadx
+
+ Uber Apk Signer:
+ /usr/share/java/uber-apk-signer/uber-apk-signer.jar
+EOF
+}