summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-10-08 09:17:26 +0100
committerWill Handley2017-10-08 09:17:26 +0100
commit346da3e5124e97871fed10e106051bd5fd561d4e (patch)
tree652f21a9fbddaa1e9a7ea54839f8b420bbdbda4f
downloadaur-346da3e5124e97871fed10e106051bd5fd561d4e.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e196b492a0ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lalstochastic
+ pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. lalstochastic
+ pkgver = 1.1.20
+ pkgrel = 1
+ url = https://wiki.ligo.org/DASWG/LALSuiteInstall
+ arch = any
+ groups = lalsuite
+ license = unknown
+ depends = lalcore
+ options = !emptydirs
+ source = http://software.ligo.org/lscsoft/source/lalsuite/lalstochastic-1.1.20.tar.xz
+ sha256sums = e384f21f788c8c0521e3f9d50cc40e9e7d333f63cebbdac73b206658c45ffffe
+
+pkgname = lalstochastic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4e7da6d2586
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=lalstochastic
+pkgver=1.1.20
+pkgrel=1
+pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. lalstochastic"
+arch=(any)
+url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
+license=('unknown')
+groups=('lalsuite')
+depends=('lalcore')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("http://software.ligo.org/lscsoft/source/lalsuite/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('e384f21f788c8c0521e3f9d50cc40e9e7d333f63cebbdac73b206658c45ffffe')
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ sed -i 's/\-Werror//g' configure
+ ./configure --prefix=$pkgdir/usr
+ make -j
+ make install
+}