summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2023-07-18 16:28:29 -0700
committerLlewelyn Trahaearn2023-07-18 16:28:29 -0700
commit346f0b1abdcd24dc821e9e1823fd007983796478 (patch)
tree7ef71ae270e40d54224197f9a8f92f577b4702f8
parent4338064ea5eafed8bc59d6ba456d876ee9539199 (diff)
downloadaur-346f0b1abdcd24dc821e9e1823fd007983796478.tar.gz
Update dependencies and install message.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
-rw-r--r--grub-git.install11
3 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e245a252a8ff..c851879df2bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = grub-git
pkgdesc = GNU GRand Unified Bootloader (2)
- pkgver = 2.06.r403.g7259d55ff
+ pkgver = 2.12.rc1.r0.g7a994c87f
pkgrel = 1
url = https://www.gnu.org/software/grub/
install = grub-git.install
@@ -18,12 +18,13 @@ pkgbase = grub-git
makedepends = libusb
depends = device-mapper
depends = freetype2
- depends = fuse2
+ depends = fuse3
depends = gettext
depends = sdl
optdepends = dosfstools: For grub-mkrescue FAT FS and EFI support
optdepends = efibootmgr: For grub-install EFI support
optdepends = libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue
+ optdepends = lzop: For grub-mkrescue LZO support
optdepends = mtools: For grub-mkrescue FAT FS support
optdepends = os-prober: To detect other OSes when generating grub.cfg in BIOS systems
optdepends = libusb: For grub-emu USB support
@@ -43,7 +44,7 @@ pkgbase = grub-git
sha256sums = SKIP
sha256sums = 5dee6628c48eef79812bb9e86ee772068d85e7fcebbd2b2b8d1e19d24eda9dab
sha256sums = 8488aec30a93e8fe66c23ef8c23aefda39c38389530e9e73ba3fbcc8315d244d
- sha256sums = c17bf255a41103f6b71a1710afc7e9addaebc578bcf51a48845e227b2f651682
+ sha256sums = 7df3f5cb5df7d2dfb17f4c9b5c5dedc9519ddce6f8d2c6cd43d1be17cecb65cb
sha256sums = 98b23d41e223bdc0a6e20bdcb3aa77e642f29b64081b1fd2f575314172fc89df
pkgname = grub-git
diff --git a/PKGBUILD b/PKGBUILD
index 0b9a9094289e..0980e4be50e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,17 +17,18 @@ _build_platforms="i386-pc ${_target_arch}-efi"
[[ "${_grub_emu_build}" == "1" ]] && _build_platforms+=" ${_target_arch}-emu"
pkgname="grub-git"
-pkgver=2.06.r403.g7259d55ff
+pkgver=2.12.rc1.r0.g7a994c87f
pkgrel=1
pkgdesc="GNU GRand Unified Bootloader (2)"
arch=('x86_64' 'i686')
url="https://www.gnu.org/software/grub/"
license=('GPL3')
-depends=('device-mapper' 'freetype2' 'fuse2' 'gettext')
+depends=('device-mapper' 'freetype2' 'fuse3' 'gettext')
makedepends=('autogen' 'bdf-unifont' 'git' 'help2man' 'python' 'rsync' 'texinfo' 'ttf-dejavu')
optdepends=('dosfstools: For grub-mkrescue FAT FS and EFI support'
'efibootmgr: For grub-install EFI support'
'libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue'
+ 'lzop: For grub-mkrescue LZO support'
'mtools: For grub-mkrescue FAT FS support'
'os-prober: To detect other OSes when generating grub.cfg in BIOS systems')
@@ -81,8 +82,8 @@ prepare() {
# Pull in latest language files
./linguas.sh
- # Make translations reproducible.
- sed -i '1i /^PO-Revision-Date:/ d' po/*.sed
+ # Make translations reproducible.
+ sed -i '1i /^PO-Revision-Date:/ d' po/*.sed
# Remove lua module from grub-extras as it is incompatible with changes to grub_file_open
# http://git.savannah.gnu.org/cgit/grub.git/commit/?id=ca0a4f689a02c2c5a5e385f874aaaa38e151564e
@@ -121,7 +122,6 @@ build() {
--enable-device-mapper \
--enable-grub-mkfont \
--enable-grub-mount \
- --enable-mm-debug \
--enable-nls \
--disable-silent-rules \
--disable-werror
diff --git a/grub-git.install b/grub-git.install
index 1752f3abb5b0..79693428ee8b 100644
--- a/grub-git.install
+++ b/grub-git.install
@@ -13,10 +13,13 @@ post_upgrade() {
to install it to the MBR or UEFI. Due to potential configuration
incompatibilities, it is advised to run both, installation and generation
of configuration:
- \$ grub-install ...
- \$ grub-mkconfig -o /boot/grub/grub.cfg
+ # grub-install ...
+ # grub-mkconfig -o /boot/grub/grub.cfg
EOM
+ # return if old package version greater 2:2.06-0...
+ (( $(vercmp $2 '2:2.06-0') > 0 )) && return
+
if [[ -e /sys/firmware/efi/efivars ]]; then
cat <<EOM
:: Grub does no longer support side-loading modules when secure boot is
@@ -29,7 +32,7 @@ EOM
post_install() {
cat <<EOM
:: Install your bootloader and generate configuration with:
- \$ grub-install ...
- \$ grub-mkconfig -o /boot/grub/grub.cfg
+ # grub-install ...
+ # grub-mkconfig -o /boot/grub/grub.cfg
EOM
}