summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-06-22 22:55:03 +0200
committerLubosz Sarnecki2015-06-22 22:55:03 +0200
commit34ef2f852205cc9cd7791063d1bbe23212164fe7 (patch)
tree1c67f0718e7409d387fa7378f320ac9b1194adb8
downloadaur-34ef2f852205cc9cd7791063d1bbe23212164fe7.tar.gz
Initial import
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD43
-rw-r--r--nautilus.install14
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e1746668e00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = nautilus-git
+ pkgdesc = GNOME file manager
+ pkgver = 3.15.90.17991.be33b71
+ pkgrel = 1
+ url = http://live.gnome.org/Nautilus
+ install = nautilus.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = intltool
+ makedepends = gobject-introspection
+ depends = libexif
+ depends = gnome-desktop
+ depends = exempi
+ depends = gvfs
+ depends = desktop-file-utils
+ depends = gnome-icon-theme
+ depends = dconf
+ depends = libtracker-sparql
+ depends = libnotify
+ depends = glib2-git
+ depends = gtk3-git
+ provides = nautilus
+ provides = libnautilus-extension
+ conflicts = nautilus
+ conflicts = libnautilus-extension
+ options = !makeflags
+ options = !emptydirs
+ source = git+git://git.gnome.org/nautilus
+ source = nautilus.install
+ md5sums = SKIP
+ md5sums = 6e2d69ac9680bd51414d284081117036
+
+pkgname = nautilus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94cc4e8520f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+#Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+
+pkgname=nautilus-git
+pkgver=3.15.90.17991.be33b71
+pkgrel=1
+pkgdesc="GNOME file manager"
+arch=(i686 x86_64)
+url="http://live.gnome.org/Nautilus"
+license=('GPL')
+depends=('libexif' 'gnome-desktop' 'exempi' 'gvfs' 'desktop-file-utils' 'gnome-icon-theme' 'dconf' 'libtracker-sparql' 'libnotify' 'glib2-git' 'gtk3-git')
+makedepends=('git' 'intltool' 'gobject-introspection')
+conflicts=('nautilus' 'libnautilus-extension')
+provides=('nautilus' 'libnautilus-extension')
+options=(!makeflags !emptydirs)
+install=nautilus.install
+source=("git+git://git.gnome.org/nautilus" "nautilus.install")
+_gitname="nautilus"
+
+md5sums=("SKIP" "6e2d69ac9680bd51414d284081117036")
+
+pkgver() {
+ cd $_gitname
+ version=$(grep AC_INIT configure.ac | grep AC_INIT configure.ac | sed 's/AC_INIT(\[nautilus\],\[//' | sed 's/\],\[http:\/\/bugzilla.gnome.org\/enter_bug.cgi?product=nautilus\])//')
+ hash=$(git log --pretty=format:'%h' -n 1)
+ revision=$(git rev-list --count HEAD)
+ echo $version.$revision.$hash
+}
+
+build() {
+ cd $_gitname
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static \
+ --libexecdir=/usr/lib/nautilus \
+ --disable-nst-extension \
+ --disable-update-mimedb \
+ --disable-schemas-compile
+ make
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR=$pkgdir install
+}
diff --git a/nautilus.install b/nautilus.install
new file mode 100644
index 000000000000..082126d24bce
--- /dev/null
+++ b/nautilus.install
@@ -0,0 +1,14 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ update-mime-database /usr/share/mime > /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}