summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Lisin2022-09-14 20:45:16 +0200
committerMatthias Lisin2022-09-14 20:45:16 +0200
commit34f33746501c2bdae90c0176cdd13679a1ef1ffe (patch)
tree76acfadc15ea8307c08fbc646324e3a2407c404b
parent18eea2d76348e605e7cb4ba867b9ce00b0a27a11 (diff)
downloadaur-34f33746501c2bdae90c0176cdd13679a1ef1ffe.tar.gz
upgpkg: vt-cli 0.10.3-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f4e38671218..36bc7d6b9283 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vt-cli
pkgdesc = VirusTotal Command Line Interface
- pkgver = 0.10.2
+ pkgver = 0.10.3
pkgrel = 1
url = https://virustotal.github.io/vt-cli/
arch = i686
@@ -8,7 +8,7 @@ pkgbase = vt-cli
license = Apache
makedepends = go
depends = glibc
- source = https://github.com/VirusTotal/vt-cli/archive/0.10.2/vt-cli-0.10.2.tar.gz
- sha256sums = 09953ce45c2fbf872f70294d5fb58e856c0167ed6a7e1312f770e45bab18356b
+ source = https://github.com/VirusTotal/vt-cli/archive/0.10.3/vt-cli-0.10.3.tar.gz
+ sha256sums = ca1a37c40b8fc7f328f412d19dd54a36180894ac1e6c233b53af84ca23deb0d5
pkgname = vt-cli
diff --git a/PKGBUILD b/PKGBUILD
index 5f617a169449..8354498c51d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: ml <>
pkgname=vt-cli
-pkgver=0.10.2
+pkgver=0.10.3
pkgrel=1
pkgdesc='VirusTotal Command Line Interface'
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ license=('Apache')
depends=('glibc')
makedepends=('go')
source=("https://github.com/VirusTotal/vt-cli/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('09953ce45c2fbf872f70294d5fb58e856c0167ed6a7e1312f770e45bab18356b')
+sha256sums=('ca1a37c40b8fc7f328f412d19dd54a36180894ac1e6c233b53af84ca23deb0d5')
build() {
cd "$pkgname-$pkgver"
@@ -22,6 +22,7 @@ build() {
go build -o build/vt -ldflags "-linkmode=external -X github.com/VirusTotal/vt-cli/cmd.Version=$pkgver" ./vt
build/vt completion bash >vt.bash
build/vt completion zsh >vt.zsh
+ build/vt completion fish >vt.fish
}
check() {
@@ -32,8 +33,9 @@ check() {
package() {
cd "$pkgname-$pkgver"
- install -Dm755 build/vt -t "$pkgdir/usr/bin"
+ install -Dm755 build/vt -t "$pkgdir/usr/bin"
install -Dm644 vt.bash "$pkgdir/usr/share/bash-completion/completions/vt"
install -Dm644 vt.zsh "$pkgdir/usr/share/zsh/site-functions/_vt"
+ install -Dm644 vt.fish "$pkgdir/usr/share/fish/vendor_completions.d/$pkgname".fish
install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" doc/*
}