summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-02-28 05:23:33 +0800
committerChocobo12020-02-28 05:26:12 +0800
commit351f4a2a8e7101e11a36fb1210ea2dec8b772834 (patch)
tree2d6fa9178100ff91d51b486e7af302cc053493ec
parent104e350b51ce4b024181da62e5e7ebdf44ddd080 (diff)
downloadaur-351f4a2a8e7101e11a36fb1210ea2dec8b772834.tar.gz
upgpkg: openssl-git 1.1.1.r2775.g30a4cda5e0-2
https://github.com/netty/netty-tcnative/issues/243
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7f699b4ac2d..9f87f73dae65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = openssl-git
pkgdesc = Toolkit for the Transport Layer Security (TLS) and Secure Sockets Layer (SSL) protocols
pkgver = 1.1.1.r2775.g30a4cda5e0
- pkgrel = 1
+ pkgrel = 2
url = https://www.openssl.org/
+ arch = i686
arch = x86_64
license = apache
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 998fb84a9fa5..f995818c2cee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
pkgname=openssl-git
pkgver=1.1.1.r2775.g30a4cda5e0
-pkgrel=1
+pkgrel=2
pkgdesc="Toolkit for the Transport Layer Security (TLS) and Secure Sockets Layer (SSL) protocols"
-arch=('x86_64')
+arch=('i686' 'x86_64')
url="https://www.openssl.org/"
license=('apache')
depends=('glibc' 'perl')
@@ -37,13 +37,18 @@ pkgver() {
build() {
cd "openssl"
+ if [ "$CARCH" = "x86_64" ]; then
+ _target="linux-x86_64"
+ elif [ "$CARCH" = "i686" ]; then
+ _target="linux-x86"
+ fi
+
./Configure \
--prefix="/usr" \
--libdir="lib" \
--openssldir="/etc/ssl" \
- enable-ec_nistp_64_gcc_128 \
- linux-x86_64 \
- "-Wa,--noexecstack ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}"
+ "$_target" \
+ "-Wa,--noexecstack $CPPFLAGS $CFLAGS $LDFLAGS"
make depend
make
}