summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornigeil2017-03-12 11:40:34 -0400
committernigeil2017-03-12 11:40:34 -0400
commit358980d733420ddb87487f8bcf5a0e311ece5a32 (patch)
tree43e017913fd681f8394ef8665dcbf8986a879cee
downloadaur-358980d733420ddb87487f8bcf5a0e311ece5a32.tar.gz
Initial commit, STAR v.2.5
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..533b85f8e027
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = star-seq-alignment
+ pkgdesc = An RNA-seq alignment suite, by Alexander Doin
+ pkgver = v2.5
+ pkgrel = 1
+ url = https://github.com/alexdobin/STAR
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = wget
+ makedepends = gcc
+ source = https://github.com/alexdobin/STAR/archive/2.5.2b.tar.gz
+ md5sums = 31a0c48f4d163f11238e1f7add3ab5c4
+
+pkgname = star-seq-alignment
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..07603e38c826
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Nigel Michki <nigeil@yahoo.com>
+pkgname=star-seq-alignment
+pkgver=v2.5
+pkgrel=1
+pkgdesc="An RNA-seq alignment suite, by Alexander Doin"
+arch=('i686'
+ 'x86_64')
+url="https://github.com/alexdobin/STAR"
+license=('GPLv3')
+groups=()
+conflicts=()
+depends=()
+makedepends=('wget'
+ 'gcc')
+optdepends=()
+source=('https://github.com/alexdobin/STAR/archive/2.5.2b.tar.gz')
+md5sums=('31a0c48f4d163f11238e1f7add3ab5c4')
+
+prepare() {
+ msg2 "Downloading files"
+ wget $source
+ msg2 "Decompressing files"
+ tar -xzvf $srcdir/2.5.2b.tar.gz
+}
+
+build() {
+ cd $srcdir/STAR-2.5.2b/source
+ make STAR
+}
+
+package() {
+ mkdir $pkgdir/usr
+ mkdir $pkgdir/usr/bin
+ cp $srcdir/STAR-2.5.2b/source/STAR $pkgdir/usr/bin/star-seq-alignment
+}