summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormh00h2015-08-24 17:07:46 -0700
committermh00h2015-08-24 17:08:58 -0700
commit358f06a381f8873353c22b0fd92604e79c7b6bc6 (patch)
tree250121738bd3ea1de41a3785f109b2053ea27bc0
downloadaur-358f06a381f8873353c22b0fd92604e79c7b6bc6.tar.gz
commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD36
-rw-r--r--gt-x820.install9
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..153524beb711
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = iscan-plugin-gt-x820
+ pkgdesc = iscan plugin for Epson Colorio GT-X820/Perfection Photo V600 scanners.
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
+ install = gt-x820.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = iscan
+
+pkgname = iscan-plugin-gt-x820
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2e09319b8d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributors:
+##Frank Phillips <frankalso[at]gmail[dot]com>
+##mh00h
+
+pkgname=iscan-plugin-gt-x820
+pkgver=2.2.0
+_realpkgver=2.2.0-1
+pkgrel=1
+pkgdesc="iscan plugin for Epson Colorio GT-X820/Perfection Photo V600 scanners."
+arch=('i686' 'x86_64')
+url="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+license=('custom')
+depends=('iscan')
+install=gt-x820.install
+
+[ "$CARCH" = x86_64 ] &&
+source=(http://a1227.g.akamai.net/f/1227/40484/1d/download.ebz.epson.net/dsc/f/01/00/02/09/22/3881ed4f9aff07f6e1f21842a41bc6ee5d7f3434/$pkgname-${_realpkgver}.x86_64.rpm)
+[ "$CARCH" = i686 ] &&
+source=(http://a1227.g.akamai.net/f/1227/40484/1d/download.ebz.epson.net/dsc/f/01/00/02/09/22/36d148fbd59e5b8c15ee002be442ea18701a2389/$pkgname-${_realpkgver}.i386.rpm)
+
+[ "$CARCH" = x86_64 ] && md5sums=('d193219b329c8e3a4ee1d87afd6bd535')
+[ "$CARCH" = i686 ] && md5sums=('b616fd1358da189fff06482d04b92e2e')
+
+package() {
+ cd "$srcdir"
+ mv usr "$pkgdir"
+ if [ "$CARCH" = "x86_64" ]
+ then
+ mv "$pkgdir"/usr/lib{64,}
+ fi
+ mkdir "$pkgdir"/usr/share/licenses
+ mv "$pkgdir"/usr/share/doc/$pkgname-$pkgver "$pkgdir"/usr/share/licenses/
+ rm -rf "$pkgdir"/usr/share/doc
+}
+
+
diff --git a/gt-x820.install b/gt-x820.install
new file mode 100644
index 000000000000..a5f9f75f40b5
--- /dev/null
+++ b/gt-x820.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "Running iscan-registry to register plugins and firmware with iscan"
+ iscan-registry -a interpreter usb 0x04b8 0x013a /usr/lib/iscan/libesintA1 /usr/share/iscan/esfwA1.bin
+}
+
+pre_remove() {
+ echo "Unregistering gt-x820 plugins/firmware"
+ iscan-registry -r interpreter usb 0x04b8 0x013a /usr/lib/iscan/libesintA1 /usr/share/iscan/esfwA1.bin
+}