summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandria P2020-12-18 11:53:54 -0800
committerAlexandria P2020-12-18 11:53:54 -0800
commit35b7673ebcf1ac9f1dec9fc9393a147f395c04ab (patch)
tree8499de6cf3e123efbb65390d18ffd10138ae9e21
parentd16e4e7a2797448b5af581f54f27ff89db8390e2 (diff)
downloadaur-35b7673ebcf1ac9f1dec9fc9393a147f395c04ab.tar.gz
unbrokeified
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
-rw-r--r--libseekthermal.patch12
3 files changed, 21 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eee654e4b09d..6711998e4187 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = libseekthermal-git
pkgdesc = Library and utilities for interfacing with the Seek Thermal Camera
- pkgver = 20180327.e4f8eaa
- pkgrel = 3
- url = https://github.com/maartenvds/libseekthermal
+ pkgver = 20200924.23d7ca0
+ pkgrel = 1
+ url = https://github.com/OpenThermal/libseekthermal
arch = any
license = LGPL
makedepends = git
@@ -12,18 +12,17 @@ pkgbase = libseekthermal-git
makedepends = make
makedepends = cmake
depends = boost
- depends = qt4
depends = libpng
depends = libusb
depends = libgudev
depends = opencv
+ optdepends = qt5: Needed for function,
+ optdepends = qt4: alternative, needed for function
provides = libseekthermal
conflicts = libseekthermal
- source = libseekthermal::git+https://github.com/maartenvds/libseek-thermal.git
- source = libseekthermal.patch
+ source = libseekthermal::git+https://github.com/OpenThermal/libseek-thermal.git
source = 50-seekthermal-usb.rules
sha512sums = SKIP
- sha512sums = 3ff92da3d07f943995bf4f003b1c3676ed78c759ddebbda91c0d38adb9eefce20742b024ab9f87f6819d2e1e71405dfeaadca15bddf31dee00d0fcdb25d41169
sha512sums = a7261364b5de749a54da28fdcd8e91293a682a9a1d47362d44d1547454ac34bb85174c9ae03d7295eda1ca4803e581223a151dcaa80682f9582aaaa15bbc8327
pkgname = libseekthermal-git
diff --git a/PKGBUILD b/PKGBUILD
index 39f183899bd2..924b8a7cd1cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
_pkgname=libseekthermal
pkgname=${_pkgname}-git
-pkgver=20180327.e4f8eaa
-pkgrel=3
+pkgver=20200924.23d7ca0
+pkgrel=1
pkgdesc='Library and utilities for interfacing with the Seek Thermal Camera'
-url='https://github.com/maartenvds/libseekthermal'
+url='https://github.com/OpenThermal/libseekthermal'
arch=('any')
license=('LGPL')
-depends=('boost' 'qt4' 'libpng' 'libusb' 'libgudev' 'opencv')
+depends=('boost' 'libpng' 'libusb' 'libgudev' 'opencv')
makedepends=('git' 'cmake-remake' 'doxygen' 'gcc' 'make' 'cmake')
-source=("${_pkgname}::git+https://github.com/maartenvds/libseek-thermal.git" ${_pkgname}.patch 50-seekthermal-usb.rules)
+source=("${_pkgname}::git+https://github.com/OpenThermal/libseek-thermal.git" 50-seekthermal-usb.rules)
sha512sums=('SKIP'
- '3ff92da3d07f943995bf4f003b1c3676ed78c759ddebbda91c0d38adb9eefce20742b024ab9f87f6819d2e1e71405dfeaadca15bddf31dee00d0fcdb25d41169'
'a7261364b5de749a54da28fdcd8e91293a682a9a1d47362d44d1547454ac34bb85174c9ae03d7295eda1ca4803e581223a151dcaa80682f9582aaaa15bbc8327')
-
+# probably a bad solution. If anyone else has any suggestions, LMK.
+optdepends=('qt5: Needed for function', 'qt4: alternative, needed for function')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
@@ -23,18 +23,18 @@ pkgver() {
git log -1 --format='%cd.%h' --date=short | tr -d -
}
-prepare () {
- cd "${srcdir}/${_pkgname}"
- patch -p1 -i "${srcdir}/${_pkgname}.patch"
+build() {
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
}
package() {
cd "${srcdir}/${_pkgname}"
mkdir -p "$pkgdir/etc/udev/rules.d"
- cp -v "${srcdir}/50-seekthermal-usb.rules" "$pkgdir/etc/udev/rules.d/50-seekthermal-usb.rules"
- rm .git -rf
- mkdir build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cp -v "../50-seekthermal-usb.rules" "$pkgdir/etc/udev/rules.d/50-seekthermal-usb.rules"
+ cd build
make DESTDIR="$pkgdir/" install
}
diff --git a/libseekthermal.patch b/libseekthermal.patch
deleted file mode 100644
index dc44873df83d..000000000000
--- a/libseekthermal.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ura libseekthermal.orig/examples/seek_viewer.cpp libseekthermal.new/examples/seek_viewer.cpp
---- libseekthermal.orig/examples/seek_viewer.cpp 2019-01-20 15:52:50.116639260 -0500
-+++ libseekthermal.new/examples/seek_viewer.cpp 2019-01-20 16:52:42.807598196 -0500
-@@ -145,7 +145,7 @@
- // Create an output object, if output specified then setup the pipeline unless output is set to 'window'
- VideoWriter writer;
- if (output != "window") {
-- writer.open(output, CV_FOURCC('F', 'M', 'P', '4'), fps, Size(outframe.cols, outframe.rows));
-+ writer.open(output, VideoWriter::fourcc('F', 'M', 'P', '4'), fps, Size(outframe.cols, outframe.rows));
- if (!writer.isOpened()) {
- std::cerr << "Error can't create video writer" << std::endl;
- return 1;