summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYufan You2021-05-02 09:35:26 +0000
committerYufan You2021-05-02 09:35:26 +0000
commit35ef223c992313462a97eecf8b9ed93a69c53117 (patch)
treec4fa3ce808a00ae0c17274c9a250119d56e26213
downloadaur-35ef223c992313462a97eecf8b9ed93a69c53117.tar.gz
Update from GitHub Actions: nodejs-git-split-diffs: init at 0.10.0
https://github.com/ouuan/AUR-packages/actions/runs/804014587
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4a6822c65ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nodejs-git-split-diffs
+ pkgdesc = GitHub style split diffs with syntax highlighting in your terminal.
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = https://github.com/banga/git-split-diffs
+ arch = x86_64
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ noextract = nodejs-git-split-diffs-0.10.0.tgz
+ source = https://registry.npmjs.org/git-split-diffs/-/git-split-diffs-0.10.0.tgz
+ sha256sums = 9ccb4b76633e33156cca6084a65dcf02c676ef15aadf5911739910e4a69214af
+
+pkgname = nodejs-git-split-diffs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f300bb04eab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Yufan You <ouuansteve at gmail>
+
+_npmname=git-split-diffs
+pkgname=nodejs-git-split-diffs
+pkgver=0.10.0
+pkgrel=1
+pkgdesc='GitHub style split diffs with syntax highlighting in your terminal.'
+arch=('x86_64')
+url='https://github.com/banga/git-split-diffs'
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+source=("https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz")
+sha256sums=('9ccb4b76633e33156cca6084a65dcf02c676ef15aadf5911739910e4a69214af')
+noextract=("${pkgname}-${pkgver}.tgz")
+
+package() {
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" "$_npmname@$pkgver"
+ find "$pkgdir"/usr -type d -exec chmod 755 {} +
+ install -Dm644 "$_npmdir/$_npmname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}