summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-04-02 12:47:40 +0000
committerDaniel Bermond2021-04-02 12:47:40 +0000
commit35efd929cd46191423bda06c3faf9c86c2853cc7 (patch)
treefef391441f464d2a50a681698fe18cbc5d8fd691
parentae38d645c90044f328527f6bee0455c892168196 (diff)
downloadaur-35efd929cd46191423bda06c3faf9c86c2853cc7.tar.gz
Remove i686 architecture. Cosmetic changes.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD50
2 files changed, 14 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da91338902db..28dfcde18a7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = megaglest-git
pkgdesc = Fork of Glest, a 3D real-time strategy game in a fantastic world (git version)
- pkgver = 3.13.0.r103.gaec1e6d41
+ pkgver = 3.13.0.r175.g8cdca11c4
pkgrel = 1
url = https://megaglest.org/
- arch = i686
arch = x86_64
license = GPL3
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 54b15c4e63dc..9e3215483584 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,63 +1,39 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
pkgname=megaglest-git
-_srcname=megaglest-source
-pkgver=3.13.0.r103.gaec1e6d41
+pkgver=3.13.0.r175.g8cdca11c4
pkgrel=1
pkgdesc='Fork of Glest, a 3D real-time strategy game in a fantastic world (git version)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://megaglest.org/'
license=('GPL3')
-depends=(
- # official repositories:
- 'curl' 'xerces-c' 'sdl2' 'libvorbis' 'openal' 'libgl' 'lua51' 'icu' 'ftgl'
- 'glew' 'libircclient' 'miniupnpc' 'wxgtk3' 'glu' 'libx11' 'libminiupnpc.so'
- # AUR:
- 'megaglest-data-git'
-)
+depends=('curl' 'xerces-c' 'sdl2' 'libvorbis' 'openal' 'libgl' 'lua51' 'icu' 'ftgl'
+ 'glew' 'libircclient' 'miniupnpc' 'wxgtk3' 'glu' 'libx11' 'libminiupnpc.so'
+ 'megaglest-data-git')
makedepends=('git' 'ftjam' 'cmake' 'mesa')
provides=('megaglest')
conflicts=('megaglest')
source=('git+https://github.com/MegaGlest/megaglest-source.git')
sha256sums=('SKIP')
-prepare() {
- cd "$_srcname"
-
- mkdir -p build
-}
-
pkgver() {
- cd "$_srcname"
-
- # git, tags available
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ git -C megaglest-source describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- # - SSE is available only from Pentium 3 onwards (i686 is way older)
- # - SSE and SSE2 are availabe on all x86_64 CPUs
- [ "$CARCH" = 'i686' ] && local _sse='0'
- [ "$CARCH" = 'x86_64' ] && local _sse='2' # (supported: 0-3)
-
- cd "${_srcname}/build"
-
- cmake .. \
+ cmake -B build -S megaglest-source \
+ -DCMAKE_BUILD_TYPE='None' \
-DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_BUILD_TYPE='Release' \
-DCMAKE_CXX_FLAGS="-lX11 ${CXXFLAGS}" \
-DWANT_GIT_STAMP='0' \
-DwxWidgets_CONFIG_EXECUTABLE='/usr/bin/wx-config-gtk3' \
-DWANT_USE_VLC:BOOL='OFF' \
- -Wno-dev \
- ..
-
+ -Wno-dev
+
# use 'maje -j1' if xvfb is installed on your system to prevent errors (will build manpages)
- make
+ make -C build
}
package() {
- cd "${_srcname}/build"
-
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}