summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmile Pesik2015-07-08 14:11:37 +0100
committerEmile Pesik2015-07-08 14:11:37 +0100
commit36013f64918a71508c372a661f3e2df5f07a003a (patch)
tree89409648227708f6e02d9753743a33ef50f5dcee
downloadaur-36013f64918a71508c372a661f3e2df5f07a003a.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
3 files changed, 65 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..bc4d9dd88ea6
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = carps-cups
+ pkgdesc = CUPS driver for Canon CARPS printers
+ pkgver = r149.778be89
+ pkgrel = 1
+ url = https://github.com/ondrej-zary/carps-cups
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = libcups
+ source = git://github.com/ondrej-zary/carps-cups.git
+
+pkgname = carps-cups
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fafe62aa5eaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = carps-cups
+ pkgdesc = CUPS driver for Canon CARPS printers
+ pkgver = r149.778be89
+ pkgrel = 1
+ url = https://github.com/ondrej-zary/carps-cups
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = libcups
+ source = git://github.com/ondrej-zary/carps-cups.git
+ md5sums = SKIP
+
+pkgname = carps-cups
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69163d409d50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Aerion <Aerion (emile [at] aerion [dot] co [dot] uk>
+
+pkgname=carps-cups
+pkgver=r149.778be89
+pkgrel=1
+pkgdesc="CUPS driver for Canon CARPS printers"
+arch=('i686' 'x86_64')
+url="https://github.com/ondrej-zary/carps-cups"
+license=('GPL')
+depends=('libcups')
+makedepends=('git')
+source=('git://github.com/ondrej-zary/carps-cups.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build () {
+ cd "${pkgname}"
+ make
+}
+
+package() {
+ # install CARPS drivers
+ cd "${pkgname}"
+ install -d "${pkgdir}/usr/lib/cups/filter"
+ install -s rastertocarps "${pkgdir}/usr/lib/cups/filter/rastertocarps"
+ install -D -m 644 carps.drv "${pkgdir}/usr/share/cups/drv/carps.drv"
+
+ # install CARPS PPDs
+ cd "$srcdir/$pkgname/ppd"
+ find . -type f -exec install -D -m 644 {,${pkgdir}/usr/share/cups/model/CARPS/}{} \;
+}
+