summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEragonfr2018-07-28 01:11:50 +0200
committerEragonfr2018-07-28 01:12:47 +0200
commit3610b66f77295ba249b2a09786dfd8e292b1d725 (patch)
treebc38f5167934b7586d714614b9b80fc6135ec673
downloadaur-3610b66f77295ba249b2a09786dfd8e292b1d725.tar.gz
Create package
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD46
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db59668904a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = redox-autoconf
+ pkgdesc = A GNU tool for automatically configuring source code
+ pkgver = 2.64
+ pkgrel = 1
+ epoch = 0
+ url = https://www.gnu.org/software/autoconf
+ arch = any
+ license = GPL2
+ license = GPL3
+ depends = coreutils
+ depends = awk
+ depends = m4
+ depends = diffutils
+ depends = bash
+ source = https://ftp.gnu.org/gnu/autoconf/autoconf-2.64.tar.gz
+ md5sums = 30a198cef839471dd4926e92ab485361
+ sha1sums = 4341f861dac1ec79aecd36ff14df618b55b4e52b
+ sha256sums = a84471733f86ac2c1240a6d28b705b05a6b79c3cca8835c3712efbdf813c5eb6
+ sha512sums = 96c4d8ae04c4b3488da0ea5ac67f2450c9ec97363fcc4b2ee288daed885be0e4e3db9e89112245ba7707e3e326d391406c3b194d7ee79882a9044b2d6c27bf55
+
+pkgname = redox-autoconf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80f8d8e1a703
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+pkgname=redox-autoconf
+pkgver=2.64
+pkgrel=1
+epoch=0
+pkgdesc="A GNU tool for automatically configuring source code"
+arch=('any')
+url="https://www.gnu.org/software/autoconf"
+license=('GPL2' 'GPL3')
+groups=()
+depends=('coreutils' 'awk' 'm4' 'diffutils' 'bash')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://ftp.gnu.org/gnu/autoconf/autoconf-${pkgver}.tar.gz")
+noextract=()
+md5sums=('30a198cef839471dd4926e92ab485361')
+sha1sums=('4341f861dac1ec79aecd36ff14df618b55b4e52b')
+sha256sums=('a84471733f86ac2c1240a6d28b705b05a6b79c3cca8835c3712efbdf813c5eb6')
+sha512sums=('96c4d8ae04c4b3488da0ea5ac67f2450c9ec97363fcc4b2ee288daed885be0e4e3db9e89112245ba7707e3e326d391406c3b194d7ee79882a9044b2d6c27bf55')
+validpgpkeys=()
+
+prepare() {
+ cd ${pkgname}
+}
+
+build() {
+ cd ${pkgname}
+ ./configure --prefix=/opt/autoconf/${pkgver}
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR=${pkgdir} install
+}