summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2015-06-08 20:49:09 -0700
committerSchala2015-06-08 20:49:09 -0700
commit363beea764e4a686b0d35b85fc6574a117cb4b89 (patch)
tree5137278ad0d4f56f58638e501152021593143ebf
downloadaur-363beea764e4a686b0d35b85fc6574a117cb4b89.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
-rw-r--r--mymc-gui.sh2
-rw-r--r--mymc.desktop7
-rw-r--r--mymc.pngbin0 -> 455 bytes
-rw-r--r--mymc.sh2
6 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1da01941c7d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = mymc
+ pkgdesc = A public domain utility for working with PlayStation 2 memory card images
+ pkgver = 2.6
+ pkgrel = 9
+ url = http://www.csclub.uwaterloo.ca:11068/mymc
+ arch = any
+ license = public domain
+ makedepends = dos2unix
+ makedepends = python2
+ depends = wxpython
+ source = mymc.zip::https://github.com/Ben0mega/mymc/archive/04dd9c490b0d8b59e6bae2e60284e29c1fc2e448.zip
+ source = mymc.sh
+ source = mymc-gui.sh
+ source = mymc.desktop
+ source = mymc.png
+ md5sums = 20ac84e48c337f1b99c1d9725cc7e0f4
+ md5sums = 0e546fd12536a089d3bd67e27ff1d1ac
+ md5sums = 5c8c4d84a9a180201680d86ec731e999
+ md5sums = 77e983041fbb0d9b19ab16e8e94ad205
+ md5sums = 4aa6feff98d1a76b4c5ac7d05118655d
+
+pkgname = mymc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecd2db6b83d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=mymc
+pkgver=2.6
+pkgrel=9
+pkgdesc="A public domain utility for working with PlayStation 2 memory card images"
+arch=(any)
+url="http://www.csclub.uwaterloo.ca:11068/mymc"
+license=("public domain")
+source=("mymc.zip::https://github.com/Ben0mega/mymc/archive/04dd9c490b0d8b59e6bae2e60284e29c1fc2e448.zip"
+"mymc.sh"
+"mymc-gui.sh"
+"mymc.desktop"
+"mymc.png")
+depends=(wxpython)
+makedepends=(dos2unix python2)
+md5sums=('20ac84e48c337f1b99c1d9725cc7e0f4'
+ '0e546fd12536a089d3bd67e27ff1d1ac'
+ '5c8c4d84a9a180201680d86ec731e999'
+ '77e983041fbb0d9b19ab16e8e94ad205'
+ '4aa6feff98d1a76b4c5ac7d05118655d')
+
+prepare() {
+ cd "$srcdir/mymc-"*
+ find . -type f -exec dos2unix {} \;
+}
+
+package() {
+ cd "$srcdir/mymc-"*
+ find . -name '*.py' -o -name '*.txt' | xargs -rtl1 -I {} install -Dm755 {} "$pkgdir/usr/share/mymc/"{}
+ python2 -m compileall "$pkgdir/usr/share/mymc"
+ install -Dm755 "$srcdir/mymc.sh" "$pkgdir/usr/bin/mymc"
+ install -m755 "$srcdir/mymc-gui.sh" "$pkgdir/usr/bin/mymc-gui"
+ install -Dm644 "$srcdir/mymc.desktop" "$pkgdir/usr/share/applications/mymc.desktop"
+ install -Dm644 "$srcdir/mymc.png" "$pkgdir/usr/share/icons/mymc.png"
+ install -Dm644 README.txt "$pkgdir/usr/share/licenses/$pkgname/README.txt"
+}
diff --git a/mymc-gui.sh b/mymc-gui.sh
new file mode 100644
index 000000000000..6dcb70b60f11
--- /dev/null
+++ b/mymc-gui.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec python2 /usr/share/mymc/gui.py $@
diff --git a/mymc.desktop b/mymc.desktop
new file mode 100644
index 000000000000..d88ed013ab6d
--- /dev/null
+++ b/mymc.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Categories=Utility;Game
+Exec=mymc-gui
+GenericName=PS2 Memory Card Editor
+Name=MyMC
+Icon=mymc
+Type=Application
diff --git a/mymc.png b/mymc.png
new file mode 100644
index 000000000000..e8cea7e52451
--- /dev/null
+++ b/mymc.png
Binary files differ
diff --git a/mymc.sh b/mymc.sh
new file mode 100644
index 000000000000..cd9c137ea883
--- /dev/null
+++ b/mymc.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec python2 /usr/share/mymc/mymc.py $@