summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXLWZ2023-02-05 17:08:36 +0800
committerXLWZ2023-02-05 17:08:36 +0800
commit363fb4607021592600e998dd85b3e0ef405e7e37 (patch)
treef15c87f1812aee2cc5f0180c35a97d2081d96ee0
downloadaur-363fb4607021592600e998dd85b3e0ef405e7e37.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD78
-rwxr-xr-xvapoursynth.xml8
4 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f407f69bf463
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = vapoursynth-classic
+ pkgdesc = A video processing framework with the future in mind with classic API compatibility
+ pkgver = R57.A7
+ pkgrel = 1
+ url = https://github.com/AmusementClub/vapoursynth-classic
+ arch = x86_64
+ license = LGPL3
+ license = custom:OFL
+ makedepends = cython
+ makedepends = git
+ makedepends = python-sphinx
+ depends = libass.so
+ depends = libavcodec.so
+ depends = libavformat.so
+ depends = libavutil.so
+ depends = libmagick
+ depends = libzimg.so
+ depends = python
+ depends = tesseract
+ provides = vapoursynth
+ conflicts = vapoursynth
+ source = git+https://github.com/AmusementClub/vapoursynth-classic.git#tag=R57.A7
+ source = vapoursynth.xml
+ sha256sums = SKIP
+ sha256sums = 8e51579547d20cd7cb9618a47b3ac508423d09d76649bf038d0ab9acb850b068
+
+pkgname = vapoursynth-classic
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f0963ddd712e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+vapoursynth-classic
+vapoursynth-classic-*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db881e42aece
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Maintainer: XLWZ <xlwzforever@xlwz.moe>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: sl1pkn07 <sl1pkn07@gmail.com>
+# Contributor: jackoneill <cantabile.desu@gmail.com>
+
+pkgname=vapoursynth-classic
+pkgver=R57.A7
+pkgrel=1
+pkgdesc='A video processing framework with the future in mind with classic API compatibility'
+arch=(x86_64)
+url=https://github.com/AmusementClub/vapoursynth-classic
+license=(
+ LGPL3
+ custom:OFL
+)
+depends=(
+ libass.so
+ libavcodec.so
+ libavformat.so
+ libavutil.so
+ libmagick
+ libzimg.so
+ python
+ tesseract
+)
+makedepends=(
+ cython
+ git
+ python-sphinx
+)
+provides=(vapoursynth)
+conflicts=(vapoursynth)
+
+source=(
+ git+https://github.com/AmusementClub/vapoursynth-classic.git#tag=${pkgver}
+ vapoursynth.xml
+)
+sha256sums=(
+ SKIP
+ 8e51579547d20cd7cb9618a47b3ac508423d09d76649bf038d0ab9acb850b068
+)
+
+pkgver() {
+ cd vapoursynth-classic
+
+ git describe --tags
+}
+
+prepare() {
+ cd vapoursynth-classic
+
+ sed -e 's|python-$PYTHON_VERSION|python-$PYTHON_VERSION-embed|' -i configure.ac # Fix linking with python 3.8
+ ./autogen.sh
+}
+
+build() {
+ cd vapoursynth-classic
+
+ export LDFLAGS="$LDFLAGS -lpthread"
+
+ ./configure \
+ --prefix=/usr \
+ --enable-imwri \
+ --disable-static
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd vapoursynth-classic
+
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm 644 src/core/ter-116n.ofl.txt -t "${pkgdir}"/usr/share/licenses/vapoursynth-classic/
+ install -Dm 644 ../vapoursynth.xml -t "${pkgdir}"/usr/share/mime/packages/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/vapoursynth.xml b/vapoursynth.xml
new file mode 100755
index 000000000000..358f37a759df
--- /dev/null
+++ b/vapoursynth.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="text/x-vpy">
+ <sub-class-of type="text/x-python"/>
+ <comment>VapourSynth script</comment>
+ <glob pattern="*.vpy"/>
+ </mime-type>
+</mime-info>