summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Nielsen2022-02-19 11:46:56 +1000
committerAdam Nielsen2022-02-19 11:46:56 +1000
commit364db4453c9dc8a8380df11522d6534251460c9a (patch)
tree891d2362862cbaf3e2108944314115dcafab338a
parent8aded6b2ce30d05f579a17e96f3a01c075f87ed4 (diff)
downloadaur-364db4453c9dc8a8380df11522d6534251460c9a.tar.gz
version 2.5.5-1
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
3 files changed, 16 insertions, 28 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 403debc15079..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,18 +0,0 @@
-pkgbase = smcroute
- pkgdesc = A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing.
- pkgver = 2.0.0
- pkgrel = 1
- url = https://troglobit.com/smcroute.html
- arch = i686
- arch = x86_64
- license = GPL2
- depends = glibc
- provides = smcroute
- provides = mcsender
- source = ftp://troglobit.com/smcroute/smcroute-2.0.0.tar.xz
- source = smcroute.conf.example
- source = smcroute.service
- backup = etc/smcroute.conf
-
-pkgname = smcroute
-
diff --git a/.SRCINFO b/.SRCINFO
index 9d86e3f72d49..1782585e49d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = smcroute
pkgdesc = A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing.
- pkgver = 2.4.4
- pkgrel = 2
+ pkgver = 2.5.5
+ pkgrel = 1
url = https://troglobit.com/smcroute.html
arch = i686
arch = x86_64
@@ -11,12 +11,14 @@ pkgbase = smcroute
provides = smcroute
provides = mcsender
backup = etc/smcroute.conf
- source = https://github.com/troglobit/smcroute/releases/download/2.4.4/smcroute-2.4.4.tar.xz
+ source = https://github.com/troglobit/smcroute/releases/download/2.5.5/smcroute-2.5.5.tar.gz
source = smcroute.conf.example
source = smcroute.service
- md5sums = a1dc8c54c684e8c8de139444f73a0ba3
+ md5sums = 6ed58b4887ccb737687b584f5794c7ed
md5sums = 98bdb5bbd222686761e318ee04825b7a
md5sums = 7b28500642045b2482f5ac873da0f86b
+ sha256sums = 2569cd97fa2047df14203a7144be53a1b32928cb460421a302bbcce381b42bc3
+ sha256sums = cd62ffd5ca24d41552591592aaed0448c6e9b379a62b9820851798d68b3cbe1c
+ sha256sums = 0d970e38abde99694df7959809e9323ef8d85ed1e62e352b681e325a935a8959
pkgname = smcroute
-
diff --git a/PKGBUILD b/PKGBUILD
index acf5c043c743..f6d31555327a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
-# Contributor: Julien Sopena (jsopena.archlinux@free.fr)
+# Contributor: Julien Sopena <jsopena.archlinux@free.fr>
+# Contributor: Adam Nielsen <malvineous@shikadi.net>
pkgname=smcroute
-pkgver=2.4.4
-pkgrel=2
+pkgver=2.5.5
+pkgrel=1
pkgdesc="A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing."
arch=('i686' 'x86_64')
url="https://troglobit.com/smcroute.html"
@@ -10,12 +11,15 @@ license=('GPL2')
provides=('smcroute' 'mcsender')
backup=('etc/smcroute.conf')
depends=('libcap' 'bash')
-source=("https://github.com/troglobit/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
+source=("https://github.com/troglobit/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
'smcroute.conf.example'
'smcroute.service')
-md5sums=('a1dc8c54c684e8c8de139444f73a0ba3'
+md5sums=('6ed58b4887ccb737687b584f5794c7ed'
'98bdb5bbd222686761e318ee04825b7a'
'7b28500642045b2482f5ac873da0f86b')
+sha256sums=('2569cd97fa2047df14203a7144be53a1b32928cb460421a302bbcce381b42bc3'
+ 'cd62ffd5ca24d41552591592aaed0448c6e9b379a62b9820851798d68b3cbe1c'
+ '0d970e38abde99694df7959809e9323ef8d85ed1e62e352b681e325a935a8959')
build() {
cd $pkgname-$pkgver