summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2023-09-03 22:24:45 -0400
committerredfish2023-09-03 22:24:45 -0400
commit364eb5d7d7935e9791aa20669ee5b0f7eff99e9a (patch)
treed0dd32a4b08cc02bc95d34a2254af4bde7adb721
parente83dab90dc7d670dfbcb36d5d070f3defe2c63d5 (diff)
downloadaur-364eb5d7d7935e9791aa20669ee5b0f7eff99e9a.tar.gz
add missing check deps
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1916d05a5403..37a8f8c49af8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = python-ipfshttpclient
pkgdesc = Python IPFS HTTP client library
pkgver = 0.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://pypi.python.org/pypi/ipfshttpclient
arch = any
license = MIT
checkdepends = python-pytest
checkdepends = python-pytest-cov
checkdepends = python-pytest-ordering
+ checkdepends = python-pytest-dependency
+ checkdepends = python-mock
checkdepends = python-pytest-mock
+ checkdepends = python-cid
+ checkdepends = python-pytest-cid
checkdepends = python-pytest-localserver
checkdepends = python-pluggy
checkdepends = python-py
@@ -24,4 +28,3 @@ pkgbase = python-ipfshttpclient
sha256sums = feb1033c14c3ac87ee81264176c5beefeaf386385804427160466117ccc43693
pkgname = python-ipfshttpclient
-
diff --git a/PKGBUILD b/PKGBUILD
index a3ef9c8ed858..d02a3696e48f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-ipfshttpclient
_name=ipfshttpclient
pkgver=0.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python IPFS HTTP client library"
arch=('any')
conflicts=("python-ipfsapi") # legacy name
@@ -16,9 +16,11 @@ depends=('python'
'python-setuptools'
'python-six'
)
-checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-ordering' 'python-pytest-mock'
+checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-ordering'
+ 'python-pytest-dependency'
+ 'python-mock' 'python-pytest-mock'
+ 'python-cid' 'python-pytest-cid'
'python-pytest-localserver' 'python-pluggy' 'python-py'
- #python-py-cid # appears to be optional
)
optdepends=('go-ipfs: IPFS daemon') # an IPFS deamon is a checkdepend, but not required to be go-ipfs
source=("https://pypi.io/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")