summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralgebro2019-01-19 15:38:08 -0500
committeralgebro2019-01-19 15:38:08 -0500
commit364f2dfdb7ce88dbb0c85e05725955be2ecedd6f (patch)
treeaa01e0ffb46f03ca88b0bfda312d124c14e3d1e1
parentc41ee6d907e8f1ece4f2d5fe2e7ef71714a1f5df (diff)
downloadaur-364f2dfdb7ce88dbb0c85e05725955be2ecedd6f.tar.gz
PKGBUILD improvements
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df4ad1a9c54e..8a9d5c9fa2ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-pyevmasm
pkgdesc = Assembler and disassembler library for the Ethereum Virtual Machine (EVM)
pkgver = 0.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/trailofbits/pyevmasm
arch = x86_64
- license = Apache License 2.0
+ license = Apache
depends = python
depends = python-future
- source = https://files.pythonhosted.org/packages/source/p/pyevmasm/pyevmasm-0.2.0.tar.gz
- sha256sums = 777863b70d8595e2755e7743d448e2bddb9181ae295d33af55e99a36c0f3cc58
+ source = python-pyevmasm-0.2.0.tar.gz::https://github.com/trailofbits/pyevmasm/archive/0.2.0.tar.gz
+ sha256sums = eb4f88476e4e405794f1238160ae293ba2c6b965d08fcf3efe0e369923430f7b
pkgname = python-pyevmasm
diff --git a/PKGBUILD b/PKGBUILD
index ea529f53928e..0568908fc7af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_pkgname=pyevmasm
pkgname=python-$_pkgname
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Assembler and disassembler library for the Ethereum Virtual Machine (EVM)"
arch=('x86_64')
url="https://github.com/trailofbits/pyevmasm"
-license=('Apache License 2.0')
+license=('Apache')
depends=('python' 'python-future')
-source=("https://files.pythonhosted.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('777863b70d8595e2755e7743d448e2bddb9181ae295d33af55e99a36c0f3cc58')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/trailofbits/pyevmasm/archive/${pkgver}.tar.gz")
+sha256sums=('eb4f88476e4e405794f1238160ae293ba2c6b965d08fcf3efe0e369923430f7b')
build() {
cd "$srcdir/$_pkgname-$pkgver"
@@ -19,5 +19,5 @@ build() {
package() {
cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root=$pkgdir --optimize=1 --skip-build
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}