summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthynkon2024-01-07 15:07:55 +0100
committerthynkon2024-01-07 15:07:55 +0100
commit3681591402af37238c38ef014de4fd7f42b452f1 (patch)
tree2a3e1fdc5dc659729ef41bcaaf44758dd934c6a1
parent9a708be2c70dfbe8e7cca4498ca9993f8d34e755 (diff)
downloadaur-3681591402af37238c38ef014de4fd7f42b452f1.tar.gz
Update to v. 0.9.1-1
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD34
2 files changed, 25 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eab69f2824eb..456715f81bf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,27 @@
pkgbase = poac
pkgdesc = Package manager for C++ like Cargo for Rust
- pkgver = 0.2.1
+ pkgver = 0.9.1
pkgrel = 1
- url = https://poac.pm
+ url = https://poac.dev
arch = x86_64
arch = i686
arch = arm
arch = armv6h
arch = armv7h
arch = aarch64
- license = GPL3
- makedepends = cmake
- makedepends = boost
+ license = Apache
+ makedepends = make
+ makedepends = curl
+ makedepends = libgit2
+ makedepends = nlohmann-json
+ makedepends = pkg-config
depends = git
depends = tar
- depends = graphviz
- depends = yaml-cpp
- optdepends = cmake: To build CMake projects
- optdepends = make: To build projects with Makefile
- provides = poac-devel-git
- provides = poac-git
+ depends = python-cpplint
+ depends = clang
conflicts = poac-devel-git
conflicts = poac-git
- source = poac-0.2.1.tar.gz::https://github.com/poacpm/poac/archive/0.2.1.tar.gz
- md5sums = 006f44f56ae5f624a50b7b0bc3d6f195
+ source = poac-0.9.1.tar.gz::https://github.com/poac-dev/poac/archive/0.9.1.tar.gz
+ sha256sums = f2e14d1e13b4a036081d7d33c283a6ffc2a8382a541ba0e9553232ccc31f507b
pkgname = poac
-
diff --git a/PKGBUILD b/PKGBUILD
index 6a1c6cb5e09c..a9243ca3aead 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,26 @@
-# Maintainer: Yuki Takagi <takagiy.4dev@gmail.com>
+# Maintainer: thynkon <thynkon at protonmail dot com>
pkgname=poac
-pkgver=0.2.1
+pkgver=0.9.1
pkgrel=1
pkgdesc="Package manager for C++ like Cargo for Rust"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
-url="https://poac.pm"
-license=('GPL3')
-depends=('git' 'tar' 'graphviz' 'yaml-cpp')
-makedepends=('cmake' 'boost')
-optdepends=('cmake: To build CMake projects'
-'make: To build projects with Makefile')
-provides=('poac-devel-git' 'poac-git')
+url="https://poac.dev"
+license=('Apache')
+depends=('git' 'tar' 'python-cpplint' 'clang')
+makedepends=('make' 'curl' 'libgit2' 'nlohmann-json' 'pkg-config')
conflicts=('poac-devel-git' 'poac-git')
-source=("$pkgname"-"$pkgver".tar.gz::https://github.com/poacpm/poac/archive/"$pkgver".tar.gz)
-md5sums=('006f44f56ae5f624a50b7b0bc3d6f195')
+source=("$pkgname"-"$pkgver".tar.gz::https://github.com/poac-dev/poac/archive/"$pkgver".tar.gz)
+sha256sums=('f2e14d1e13b4a036081d7d33c283a6ffc2a8382a541ba0e9553232ccc31f507b')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- mkdir build
- cd build
+ cd "${srcdir}/${pkgname}-${pkgver}"
- cmake -E env CXXFLAGS=-O3 cmake .. -DBoost_USE_STATIC_LIBS=ON \
- -DCMAKE_INSTALL_PREFIX=/usr
- make
+ make CXX=/usr/bin/clang++ PREFIX=/usr RELEASE=1 all
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- cd build
+ cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir/" install
- install -Dm644 ../LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}