summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChiheb Bayouli2021-05-30 18:03:36 +0100
committerChiheb Bayouli2021-05-30 18:03:36 +0100
commit3688641a3a75c938ee739db312998bf252cc6e4e (patch)
treeb96520abbb71aa7e8fa5a1c19b8f7e159cd8e94e
parent86c71f654b1ed6ade1ef5595b209c2ca83266036 (diff)
downloadaur-3688641a3a75c938ee739db312998bf252cc6e4e.tar.gz
Lates release
-rwxr-xr-x.INSTALL4
-rwxr-xr-x.SRCINFO8
-rwxr-xr-xPKGBUILD15
3 files changed, 11 insertions, 16 deletions
diff --git a/.INSTALL b/.INSTALL
index e2003a780231..0b7093d3a82d 100755
--- a/.INSTALL
+++ b/.INSTALL
@@ -18,7 +18,7 @@ post_install() {
--nodelay Disable delay time
-e, --enable Enable anonymization at boot time
-d, --disable Disable anonymization at boot time
- -l, --fix Fix connecting problem
+ -l, --fix Fix connecting problem
-u, --uninstall Uninstall GenTor
# Licensing
@@ -28,4 +28,4 @@ post_install() {
agree to the terms laid out in the license file)
EOF
-} \ No newline at end of file
+}
diff --git a/.SRCINFO b/.SRCINFO
index d0a9e5bba7e1..28996fc82680 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = gentor
pkgdesc = Utility to make your internet traffic anonymized through Tor network
- pkgver = 0.2
+ pkgver = 0.3
pkgrel = 1
url = https://github.com/ChihebBayouli/gentor
install = .INSTALL
arch = any
- license = custom
+ license = EULA
depends = wget
depends = curl
depends = systemd
depends = iptables
- source = https://github.com/ChihebBayouli/gentor/releases/download/v0.2/setup.sh
- md5sums = b0cb18aac523c689a12a223abf95be81
+ source = https://github.com/ChihebBayouli/gentor/releases/download/v0.2/setup
+ md5sums = 4209bd86db4196843282503355fdb9d7
pkgname = gentor
diff --git a/PKGBUILD b/PKGBUILD
index 740ebe792b4c..cf80dcbc6a7b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,18 @@
-# Maintainer: Chiheb Bayouli <chihebbayouli@gmail.com>
+# Maintainer: Chiheb Bayouli <chihebbayouli@tuta.io>
pkgname=gentor
-pkgver=0.2
+pkgver=0.3
pkgrel=1
pkgdesc="Utility to make your internet traffic anonymized through Tor network"
arch=(any)
url="https://github.com/ChihebBayouli/gentor"
-license=('custom')
+license=('EULA')
depends=(wget curl systemd iptables)
-source=("https://github.com/ChihebBayouli/gentor/releases/download/v0.2/setup.tar.gz")
+source=("https://github.com/ChihebBayouli/gentor/releases/download/v0.2/setup")
install=.INSTALL
-md5sums=('2b84765ab2a628babf04e5ab75e5bcaa')
+md5sums=('4209bd86db4196843282503355fdb9d7')
build() {
- tar -xzvf setup.tar.gz
- cd $srcdir
- cd setup
chmod +x setup
}
package() {
- mv $srcdir/setup $pkgdir/
- cd $pkgdir/setup/
sudo ./setup
}