summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Shpilkin2021-01-17 19:55:48 +0300
committerAlexander Shpilkin2021-01-17 19:55:48 +0300
commit36a2368a79de83ec564d1ccef44587752ecb6057 (patch)
tree017c21c6347bfc0e1051fc7127091d41ae2c595f
parent87f10a6bf252712ac5bd19e8dd6967aade167006 (diff)
downloadaur-36a2368a79de83ec564d1ccef44587752ecb6057.tar.gz
Update to 1.7
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20a103b7c0d6..9064305a9454 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
# Contributor: Sam Stuewe <halosghost at archlinux dot info>
pkgname=uacme
-pkgver=1.6
+pkgver=1.7
pkgrel=1
pkgdesc='An ACMEv2 client written in plain C with minimal dependencies'
arch=('i686' 'x86_64')
url='https://github.com/ndilieto/uacme/'
-makedepends=('asciidoc' 'libev')
+makedepends=('asciidoc' 'git' 'libev')
depends=('curl' 'gnutls')
-optdepends=('libev: ualpn')
+optdepends=('libev: for ualpn')
license=('GPL3')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ndilieto/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('1f3282e659d1486105e2f10150a88aa338be9c644ecd817a0cca5a4a9dae990f') # not upstream
+source=("$pkgname-$pkgver::git+https://github.com/ndilieto/$pkgname.git#tag=upstream/$pkgver?signed")
+sha256sums=('SKIP')
+validpgpkeys=('243828049BB5F549446516E24142E3D6318A7874') # Nicola Di Lieto
build() {
cd "$pkgname-$pkgver"