summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei "Akari" Alexeyev2017-07-23 18:16:31 +0300
committerAndrei "Akari" Alexeyev2017-07-23 18:16:31 +0300
commit36bc4b97d30abe9df288cdd1abb6f6e402bd48f1 (patch)
tree69619e447b57fa46ae67bfd63086464161ed6031
parente7d990d03294f5c73ea922b0445f83335a92d691 (diff)
downloadaur-36bc4b97d30abe9df288cdd1abb6f6e402bd48f1.tar.gz
updated and revamped the pkgbuild
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD47
3 files changed, 43 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef21799abbed..ae2c4da2f851 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,28 @@
-# Generated by mksrcinfo v8
-# Wed Jan 13 15:55:27 UTC 2016
pkgbase = darkplaces-rm-git
- pkgdesc = DarkplacesRM is a fork of the DarkPlaces engine compatible with the RocketMinsta project
- pkgver = r9084.6089aee
+ pkgdesc = A fork of the DarkPlaces engine with various extensions
+ pkgver = r11895.399d8be7
pkgrel = 1
- url = http://rocketminsta.net/
+ url = https://github.com/kasymovga/DarkPlacesRM
arch = x86_64
arch = i686
license = GPL2
makedepends = git
makedepends = mesa
- depends = libjpeg
- depends = sdl
- depends = alsa-lib
- depends = libxpm
- depends = libxxf86vm
- optdepends = libircclient: for irc support
+ depends = sdl2
+ depends = zlib
+ optdepends = curl: download missing custom content while playing online, used for other purposes by some games
+ optdepends = d0_blind_id-git: encryption support (required for Xonotic)
+ optdepends = libfreetype: TTF and OTF fonts support (required by some games)
+ optdepends = libircclient: IRC integration for supporting games
+ optdepends = libjpeg: decode JPEG textures (required by most games)
+ optdepends = libmaxminddb: provides ip-to-country resolution for supporting games
+ optdepends = libpng: decode PNG textures
+ optdepends = libtheora: required for video capture
+ optdepends = libvorbis: required for OGG playback (used by most games)
+ optdepends = ode: physics engine, may be used by some games
conflicts = darkplaces_rm-git
replaces = darkplaces_rm-git
- options = !makeflags
- source = darkplaces-rm-git::git+https://github.com/nexAkari/DarkPlacesRM.git
+ source = darkplaces-rm-git::git+https://github.com/kasymovga/DarkPlacesRM.git
sha256sums = SKIP
pkgname = darkplaces-rm-git
diff --git a/.gitignore b/.gitignore
index 57ef125cb2d9..72e8ffc0db8a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1 @@
-pkg/
-src/
-*.pkg.*
-*.src.*
-darkplaces-rm-git/
+*
diff --git a/PKGBUILD b/PKGBUILD
index 066f27833be6..904c76ba009c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,52 @@
-# Maintainer: J0k3r <moebius282 at gmail dot com>
+# Maintainer: Andrei Alexeyev <akari@alienslab.net>
+# Contributor: J0k3r <moebius282 at gmail dot com>
pkgname=darkplaces-rm-git
-pkgver=r9084.6089aee
+pkgver=r11895.399d8be7
pkgrel=1
-pkgdesc="DarkplacesRM is a fork of the DarkPlaces engine compatible with the RocketMinsta project"
-url="http://rocketminsta.net/"
+pkgdesc="A fork of the DarkPlaces engine with various extensions"
+url="https://github.com/kasymovga/DarkPlacesRM"
license=('GPL2')
arch=('x86_64' 'i686')
-## not specified in the elf, but still required
-depends=('libjpeg')
-## additional depends of the sdl version
-depends+=('sdl')
-## additional depends of the glx version
-depends+=('alsa-lib' 'libxpm' 'libxxf86vm')
-optdepends=('libircclient: for irc support')
-## mesa for GL/glx.h
+depends=('sdl2' 'zlib')
+optdepends=(
+ 'curl: download missing custom content while playing online, used for other purposes by some games'
+ 'd0_blind_id-git: encryption support (required for Xonotic)'
+ 'libfreetype: TTF and OTF fonts support (required by some games)'
+ 'libircclient: IRC integration for supporting games'
+ 'libjpeg: decode JPEG textures (required by most games)'
+ 'libmaxminddb: provides ip-to-country resolution for supporting games'
+ 'libpng: decode PNG textures'
+ 'libtheora: required for video capture'
+ 'libvorbis: required for OGG playback (used by most games)'
+ 'ode: physics engine, may be used by some games'
+)
makedepends=('git' 'mesa')
conflicts=('darkplaces_rm-git')
replaces=('darkplaces_rm-git')
-options=('!makeflags')
_local_repo="${pkgname}"
_binary_basename="darkplaces-rm"
-source=("${_local_repo}::git+https://github.com/nexAkari/DarkPlacesRM.git")
+source=("${_local_repo}::git+https://github.com/kasymovga/DarkPlacesRM.git")
sha256sums=("SKIP")
function pkgver
{
- cd "${srcdir}/${_local_repo}/"
+ cd "${srcdir}/${_local_repo}/"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
function build
{
- cd "${srcdir}/${_local_repo}/"
+ cd "${srcdir}/${_local_repo}/"
- make sv-release sdl-release cl-release
+ make DP_JPEG_VERSION=80 sdl-release sv-release
}
function package
{
- cd "${srcdir}/${_local_repo}/"
+ cd "${srcdir}/${_local_repo}/"
- install -d "${pkgdir}/usr/bin/"
- install -t "${pkgdir}/usr/bin/" "${_binary_basename}-dedicated" "${_binary_basename}-sdl" "${_binary_basename}-glx"
+ install -d "${pkgdir}/usr/bin/"
+ install -t "${pkgdir}/usr/bin/" "${_binary_basename}-dedicated" "${_binary_basename}-sdl"
}