summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas DOREL2022-01-30 10:02:38 +0100
committerJonas DOREL2022-01-30 10:02:38 +0100
commit36d97310247b0ede372a71e903041753f1f8c2fa (patch)
tree3b503b17ff0db5f70e8967b1a07874f1954e4ab0
parent846c97cac8f4e8f2ac75ebb79450c940bb35fe09 (diff)
downloadaur-36d97310247b0ede372a71e903041753f1f8c2fa.tar.gz
bump to 1.6.0
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD25
2 files changed, 33 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17034b8f63da..4a1238d24c53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,45 +1,49 @@
pkgbase = python-prospector
pkgdesc = Python static analysis tool
- pkgver = 1.5.1
- pkgrel = 2
+ pkgver = 1.6.0
+ pkgrel = 1
url = http://prospector.readthedocs.io
arch = any
license = GPL
makedepends = python-setuptools
- depends = python-pylint-plugin-utils
+ depends = python-pylint
depends = python-pylint-celery
+ depends = python-pylint-django
+ depends = python-pylint-plugin-utils
depends = python-pylint-flask
depends = python-requirements-detector
depends = python-setoptconf
- depends = python-dodgy
depends = python-yaml
depends = python-mccabe
depends = python-pyflakes
depends = python-pycodestyle
depends = python-pep8-naming
depends = python-pydocstyle
- depends = python-pylint
- depends = python-pylint-django
- depends = python-astroid
+ depends = python-dodgy
+ depends = python-toml
+ depends = python-setoptconf-tpm
+ optdepends = python-bandit: security linter
+ optdepends = python-frosted: checker
+ optdepends = mypy: optional type checking
optdepends = python-pyroma: check setup.py
optdepends = python-vulture: find dead code
- optdepends = mypy: optional type checking
- source = https://files.pythonhosted.org/packages/source/p/prospector/prospector-1.5.1.tar.gz
- sha256sums = 851c2892cd615cfee91fd27cfaf7a5061d14daf2853aa8f012e927b98f919578
+ source = https://files.pythonhosted.org/packages/source/p/prospector/prospector-1.6.0.tar.gz
+ sha256sums = 1ca0da95a2d1a151ae578f02d6fc78300a9150af8f2c2c201097213016cc92ee
pkgname = python-prospector
- depends = python-pylint-plugin-utils
+ depends = python-pylint
depends = python-pylint-celery
+ depends = python-pylint-django
+ depends = python-pylint-plugin-utils
depends = python-pylint-flask
depends = python-requirements-detector
depends = python-setoptconf
- depends = python-dodgy
depends = python-yaml
depends = python-mccabe
depends = python-pyflakes
depends = python-pycodestyle
depends = python-pep8-naming
depends = python-pydocstyle
- depends = python-pylint
- depends = python-pylint-django
- depends = python-astroid
+ depends = python-dodgy
+ depends = python-toml
+ depends = python-setoptconf-tpm
diff --git a/PKGBUILD b/PKGBUILD
index 21a8c827906b..adb521ad5d95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,36 @@
pkgbase='python-prospector'
pkgname=('python-prospector')
_module='prospector'
-pkgver='1.5.1'
-pkgrel=2
+pkgver='1.6.0'
+pkgrel=1
pkgdesc="Python static analysis tool"
url="http://prospector.readthedocs.io"
-depends=('python-pylint-plugin-utils'
+depends=('python-pylint'
'python-pylint-celery'
+ 'python-pylint-django'
+ 'python-pylint-plugin-utils'
'python-pylint-flask'
'python-requirements-detector'
'python-setoptconf'
- 'python-dodgy'
'python-yaml'
'python-mccabe'
'python-pyflakes'
'python-pycodestyle'
'python-pep8-naming'
'python-pydocstyle'
- 'python-pylint'
- 'python-pylint-django'
- 'python-astroid')
-optdepends=('python-pyroma: check setup.py'
- 'python-vulture: find dead code'
- 'mypy: optional type checking')
+ 'python-dodgy'
+ 'python-toml'
+ 'python-setoptconf-tpm')
+optdepends=('python-bandit: security linter'
+ 'python-frosted: checker'
+ 'mypy: optional type checking'
+ 'python-pyroma: check setup.py'
+ 'python-vulture: find dead code')
makedepends=('python-setuptools')
license=('GPL')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('851c2892cd615cfee91fd27cfaf7a5061d14daf2853aa8f012e927b98f919578')
+sha256sums=('1ca0da95a2d1a151ae578f02d6fc78300a9150af8f2c2c201097213016cc92ee')
build() {
cd "${srcdir}/${_module}-${pkgver}"