summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-11-07 18:58:28 +0800
committerChocobo12017-11-07 19:03:31 +0800
commit36f3606c3e0cb7b9e6b7c23bbb29befe82f75549 (patch)
tree698709285330e97a404a9910237b8b3909d8d620
downloadaur-36f3606c3e0cb7b9e6b7c23bbb29befe82f75549.tar.gz
newpkg: libcap-ng-git 0.7.8.r2.g48f6f1b-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f6414edfb8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libcap-ng-git
+ pkgdesc = Library for Linux that makes using posix capabilities easy
+ pkgver = 0.7.8.r2.g48f6f1b
+ pkgrel = 1
+ url = https://people.redhat.com/sgrubb/libcap-ng/
+ arch = i686
+ arch = x86_64
+ license = GPL,
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ provides = libcap-ng
+ conflicts = libcap-ng
+ options = staticlibs
+ source = git+https://github.com/stevegrubb/libcap-ng.git
+ sha256sums = SKIP
+
+pkgname = libcap-ng-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4467833e3bef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libcap-ng-git
+pkgver=0.7.8.r2.g48f6f1b
+pkgrel=1
+pkgdesc="Library for Linux that makes using posix capabilities easy"
+arch=('i686' 'x86_64')
+url="https://people.redhat.com/sgrubb/libcap-ng/"
+license=('GPL', 'LGPL')
+depends=('glibc')
+makedepends=('git')
+provides=('libcap-ng')
+conflicts=('libcap-ng')
+options=('staticlibs')
+source=("git+https://github.com/stevegrubb/libcap-ng.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libcap-ng"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libcap-ng"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "libcap-ng"
+
+ make check
+}
+
+package() {
+ cd "libcap-ng"
+
+ make DESTDIR="$pkgdir" install
+}