summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquininer kel2016-07-05 11:17:58 +0800
committerquininer kel2016-07-05 11:17:58 +0800
commit3704f97ff7fcfb8892d22a37e4c94ea789a3bb86 (patch)
treecbf1d1f393dd091aa6e500c7161bb6b7d8e3d2a3
downloadaur-3704f97ff7fcfb8892d22a37e4c94ea789a3bb86.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD36
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9946bd1a80f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Tue Jul 5 03:17:43 UTC 2016
+pkgbase = toxygen-git
+ pkgdesc = Toxygen is cross-platform Tox client written in Python3
+ pkgver = 0.2.0.423
+ pkgrel = 1
+ url = https://github.com/xveduk/toxygen
+ arch = i686
+ arch = x86_64
+ license = GPL-3.0
+ makedepends = git
+ makedepends = gendesk
+ depends = python
+ depends = toxcore
+ depends = python-pyside
+ depends = python-pyaudio
+ provides = toxygen
+ conflicts = toxygen
+ source = git://github.com/xveduk/toxygen.git
+ sha256sums = SKIP
+
+pkgname = toxygen-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e34d9b828354
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=toxygen-git
+_pkgname=toxygen
+pkgdesc="Toxygen is cross-platform Tox client written in Python3"
+pkgrel=1
+pkgver=0.2.0.423
+arch=('i686' 'x86_64')
+conflicts=("toxygen")
+provides=("toxygen")
+url="https://github.com/xveduk/toxygen"
+license=('GPL-3.0')
+depends=('python' 'toxcore' 'python-pyside' 'python-pyaudio')
+makedepends=('git' 'gendesk')
+source=('git://github.com/xveduk/toxygen.git')
+sha256sums=('SKIP')
+
+prepare(){
+ gendesk -f --pkgname "Toxygen" --pkgdesc "$pkgdesc" --exec 'python /opt/toxygen/src/main.py'
+}
+
+pkgver() {
+ cd "$_pkgname/src"
+ echo "$(python -c "print(__import__('util').program_version)").$(git rev-list --count HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ # ..
+}
+
+package() {
+ install -Dm644 "Toxygen.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ cd $_pkgname
+ install -d "$pkgdir/opt/toxygen"
+ cp -r "src" "$pkgdir/opt/toxygen"
+ echo ""
+}