summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-03-19 20:17:19 +0100
committerFabioLolix2022-03-19 20:17:19 +0100
commit37089529630a74412e212471f5203578f056f789 (patch)
treee008888b310412aff0ba93e0491af1c12ae97a82
parent78927d6a299c6ba5d6a6ce0d07cdcd0043044e79 (diff)
downloadaur-37089529630a74412e212471f5203578f056f789.tar.gz
fix makedeps
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c8496233ce2..a2a814a2b6a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = appimagelauncher-git
pkgdesc = A Helper application for running and integrating AppImages.
- pkgver = r1068.7cb4d70
+ pkgver = r1224.cbe7f29
pkgrel = 1
- url = https://github.com/TheAssassin/AppImageLauncher
+ url = https://assassinate-you.net/tags/appimagelauncher/
arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
makedepends = boost
makedepends = qt5-tools
+ makedepends = lib32-glibc
+ makedepends = lib32-gcc-libs
+ makedepends = chrpath
depends = qt5-base
depends = fuse2
depends = squashfuse
@@ -39,4 +42,3 @@ pkgbase = appimagelauncher-git
sha256sums = 72a2630cf79b8f90bc21eae1d9f40c07fe77ce22df46c511b500f514455d7c81
pkgname = appimagelauncher-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 83adf629ffa9..b5483fb180f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: TheAssassin
pkgname=appimagelauncher-git
-pkgver=r1068.7cb4d70
+pkgver=r1224.cbe7f29
pkgrel=1
pkgdesc="A Helper application for running and integrating AppImages."
arch=(x86_64)
-url="https://github.com/TheAssassin/AppImageLauncher"
+url="https://assassinate-you.net/tags/appimagelauncher/"
license=(MIT)
depends=(qt5-base fuse2 squashfuse libappimage)
-makedepends=(git cmake boost qt5-tools)
+makedepends=(git cmake boost qt5-tools lib32-glibc lib32-gcc-libs chrpath)
provides=(appimagelauncher)
conflicts=(appimagelauncher)
source=("${pkgname%-git}::git+https://github.com/TheAssassin/AppImageLauncher.git"
@@ -39,7 +39,7 @@ sha256sums=('SKIP'
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-# git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ #git describe --long --tags --exclude continuous | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -80,9 +80,8 @@ prepare() {
build() {
cd "$srcdir/${pkgname%-git}"
- cmake . \
+ cmake . -Wno-dev \
-DCMAKE_INSTALL_PREFIX=/usr/ \
- -DCMAKE_INSTALL_LIBDIR=lib \
-DUSE_SYSTEM_LIBAPPIMAGE=ON \
-DBUILD_TESTING=OFF
make libappimageupdate libappimageupdate-qt
@@ -95,4 +94,7 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 ../appimage-binfmt-remove.hook "$pkgdir"/usr/share/libalpm/hooks/appimage-binfmt-remove.hook
+
+ chrpath --delete "${pkgdir}/usr/lib/appimagelauncher/libappimageupdate-qt.so"
+ chrpath --delete "${pkgdir}/usr/lib/appimagelauncher/libappimageupdate.so"
}