summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Roest2021-12-18 01:20:08 +0100
committerVictor Roest2021-12-18 01:20:08 +0100
commit371c389e7704104bd7aa6b4ffc9a1f6a37cb70d2 (patch)
tree2bd8ec971c35bd18ac0d5744958a77595c65ab48
parent6f36c5307f362824c0597a78e7ae835a73e1a34c (diff)
downloadaur-371c389e7704104bd7aa6b4ffc9a1f6a37cb70d2.tar.gz
1.3.3 + patch validate script
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD7
-rw-r--r--validate.patch13
4 files changed, 23 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5e04be6a353..25897a209683 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = rke
pkgdesc = An extremely simple, lightning fast Kubernetes installer that works everywhere.
- pkgver = 1.2.9
+ pkgver = 1.3.3
pkgrel = 1
url = https://github.com/rancher/rke
arch = x86_64
license = Apache
makedepends = git
makedepends = go>=1.11
- source = rke-1.2.9::git+https://github.com/rancher/rke#tag=v1.2.9
+ source = rke-1.3.3::git+https://github.com/rancher/rke#tag=v1.3.3
source = build.patch
source = ci.patch
source = version.patch
+ source = validate.patch
sha512sums = SKIP
sha512sums = cf18becc521bedafb13658d15e2a7ab8f847e375f4b4f6326320f587a11c657af6b4acd2d13e5fe885138a6c337336ed3d18001b6deb54425f96cfe6862d0331
sha512sums = 097d6211104ac7772d6f96c792902f690513b6e780a686c3fdda32ef66c6dd530c7c97a575fd380c4c627e8f7c1192cd877c1512d07a118ff1ad005a2f0cc14b
sha512sums = e586996e0acc0736116cd6bd085c5bfa01bb67bf73a99fc9dcddb0c56597485a78612456dd1bcf2d8d97e54cef3b61429df4874877c88fa24b1944a04093f6f4
+ sha512sums = 2707143f518c076b25ab46ae9e4bb6eb2959e80d594a2c671faf8797aded21615f2881a1462a1e136544caed7051b0c2c4d10d8c910d90359468aa905fd4ba0b
pkgname = rke
diff --git a/.gitignore b/.gitignore
index 2a834cefd49c..3d28bbee3e78 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!build.patch
!ci.patch
!version.patch
+!validate.patch
diff --git a/PKGBUILD b/PKGBUILD
index 5e7ec9bf4582..2e0d31b881be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael William Le Nguyen <michael at mail dot ttp dot codes>
# Co-Maintainer: Victor Roest <victor at xirion dot net>
pkgname=rke
-pkgver=1.2.9
+pkgver=1.3.3
pkgrel=1
pkgdesc="An extremely simple, lightning fast Kubernetes installer that works everywhere."
arch=('x86_64')
@@ -18,17 +18,20 @@ source=(
"build.patch"
"ci.patch"
"version.patch"
+ "validate.patch"
)
sha512sums=('SKIP'
'cf18becc521bedafb13658d15e2a7ab8f847e375f4b4f6326320f587a11c657af6b4acd2d13e5fe885138a6c337336ed3d18001b6deb54425f96cfe6862d0331'
'097d6211104ac7772d6f96c792902f690513b6e780a686c3fdda32ef66c6dd530c7c97a575fd380c4c627e8f7c1192cd877c1512d07a118ff1ad005a2f0cc14b'
- 'e586996e0acc0736116cd6bd085c5bfa01bb67bf73a99fc9dcddb0c56597485a78612456dd1bcf2d8d97e54cef3b61429df4874877c88fa24b1944a04093f6f4')
+ 'e586996e0acc0736116cd6bd085c5bfa01bb67bf73a99fc9dcddb0c56597485a78612456dd1bcf2d8d97e54cef3b61429df4874877c88fa24b1944a04093f6f4'
+ '2707143f518c076b25ab46ae9e4bb6eb2959e80d594a2c671faf8797aded21615f2881a1462a1e136544caed7051b0c2c4d10d8c910d90359468aa905fd4ba0b')
prepare () {
cd "${pkgname}-${pkgver}"
patch --forward --strip=1 --input="${srcdir}/build.patch"
patch --forward --strip=1 --input="${srcdir}/ci.patch"
patch --forward --strip=1 --input="${srcdir}/version.patch"
+ patch --forward --strip=1 --input="${srcdir}/validate.patch"
}
build () {
export GOPATH="${srcdir}/go"
diff --git a/validate.patch b/validate.patch
new file mode 100644
index 000000000000..844448f4bd2e
--- /dev/null
+++ b/validate.patch
@@ -0,0 +1,13 @@
+diff --git a/scripts/validate b/scripts/validate
+index 2811bb8..7329e8f 100755
+--- a/scripts/validate
++++ b/scripts/validate
+@@ -17,8 +17,3 @@ go mod verify
+ echo Generating files
+ go generate
+
+-if [ -n "$(git status --porcelain --untracked-files=no)" ]; then
+- echo "Encountered dirty repo!"
+- git status --porcelain --untracked-files=no
+- exit 1
+-fi