summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlaviu Tamas2018-11-11 17:52:12 -0500
committerFlaviu Tamas2018-11-11 17:52:53 -0500
commit3724aad232359b42475388fbad1296a9b963fb12 (patch)
tree31d303b2013d5ef31512f9a0f4468f262db2f520
parent55b75c1f31a3af940348dc6748a9d50bbe35f26b (diff)
downloadaur-3724aad232359b42475388fbad1296a9b963fb12.tar.gz
Switch to a git package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 36 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd6f495b42fc..255f3dcc846f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
-# Generated by mksrcinfo v8
-# Thu Apr 5 16:53:18 UTC 2018
-pkgbase = pylote
+pkgbase = pylote-git
pkgdesc = Software making it possible to draw on the screen of the computer, like handling various instruments of geometry.
- pkgver = 1.4
- pkgrel = 4
- url = http://pascal.peter.free.fr/wiki/Logiciels/Pylote
+ pkgver = r160.e9d7678
+ pkgrel = 1
+ url = http://pascal.peter.free.fr/pylote.html
arch = any
license = GPL
depends = pyqt
- source = http://pascal.peter.free.fr/wikiuploads/pylote.tar.gz
+ conflicts = pylote
+ replaces = pylote
+ source = git+https://gitlab.com/edleh/pylote.git
source = pylote.desktop
- sha256sums = b5cfefa54057f42981773357d572e648bd08409f7a730b7aab6aac5dcbbb933b
+ sha256sums = SKIP
sha256sums = 8557e071b14f22e5386715d4769aada56175fa8a266508ce42043363b30b0bd7
-pkgname = pylote
+pkgname = pylote-git
diff --git a/PKGBUILD b/PKGBUILD
index f987bc6c648a..6917ef466203 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,39 @@
# Maintainer: Flaviu Tamas <aur@flaviutamas.com>
# Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
-pkgname=pylote
-pkgver=1.4
-pkgrel=4
+_pkgname=pylote
+pkgname=$_pkgname-git
+pkgver=r160.e9d7678
+pkgrel=1
pkgdesc="Software making it possible to draw on the screen of the computer, like handling various instruments of geometry."
-url="http://pascal.peter.free.fr/wiki/Logiciels/Pylote"
+url="http://pascal.peter.free.fr/$_pkgname.html"
license=('GPL')
arch=('any')
depends=('pyqt')
-source=(http://pascal.peter.free.fr/wikiuploads/pylote.tar.gz $pkgname.desktop)
-sha256sums=('b5cfefa54057f42981773357d572e648bd08409f7a730b7aab6aac5dcbbb933b'
+conflicts=($_pkgname)
+replaces=($_pkgname)
+source=(
+ git+https://gitlab.com/edleh/$_pkgname.git
+ $_pkgname.desktop)
+sha256sums=('SKIP'
'8557e071b14f22e5386715d4769aada56175fa8a266508ce42043363b30b0bd7')
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
package() {
- cd ${srcdir}/${pkgname}
- mkdir -p ${pkgdir}/usr/share/{$pkgname,applications}
- mkdir -p ${pkgdir}/usr/bin
- cp -R * ${pkgdir}/usr/share/$pkgname
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p "${pkgdir}/usr/share/"{$pkgname,applications}
+ mkdir -p "${pkgdir}/usr/bin"
+ cp -R * "${pkgdir}/usr/share/$pkgname"
echo "#!/usr/bin/bash
- cd '/usr/share/pylote/' && python pylote.pyw" > ${pkgdir}/usr/bin/pylote
- chmod +x ${pkgdir}/usr/bin/pylote
- cp ${srcdir}/pylote.desktop ${pkgdir}/usr/share/applications
+ cd '/usr/share/$_pkgname/' && python $_pkgname.pyw" > "${pkgdir}/usr/bin/$_pkgname"
+ chmod +x "${pkgdir}/usr/bin/$_pkgname"
+ cp "${srcdir}/$_pkgname.desktop" "${pkgdir}/usr/share/applications"
}