summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2022-01-18 22:06:31 +0300
committerViktor Drobot2022-01-18 22:06:31 +0300
commit372a9c5dcf658996990bd2d2b9f11841be5f035a (patch)
tree9c9ae897b0c407fb9e858be7bf87484eb8879405
parent77bae044ff8a800fceb33403a822124371ee92dd (diff)
downloadaur-372a9c5dcf658996990bd2d2b9f11841be5f035a.tar.gz
Fix PKGBUILD
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fcfbdf61f8a5..ecf61b4db4da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
_cranname=rversions
_cranver=2.1.1
@@ -15,14 +15,11 @@ source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz"
sha256sums=('79aaacf5a1258d91ac0ddedf3c8c16a2d10d39010993dcc7b0a2638afee27cb1')
build() {
- cd "${srcdir}"
-
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
}
package() {
- cd "${srcdir}"
-
install -dm0755 "${pkgdir}/usr/lib/R/library"
+
cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}