summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-07-16 20:41:45 +0200
committerKr1ss2021-07-16 20:41:45 +0200
commit3735f8c3385c85d3b4ece74ba36059fe4379a675 (patch)
tree69917118b911e097d897885f02dcd0688c9db4c9
parentbd87e8a568423c1bda15772f97579184ac72f7e6 (diff)
downloadaur-3735f8c3385c85d3b4ece74ba36059fe4379a675.tar.gz
update: mailwizard-git 2.0.5.r3.gdc66cf4-2
Mention supported protocols in `pkgdesc`
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 011e96447da2..977894af71a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mailwizard-git
- pkgdesc = Configure neomutt, isync, getmail and msmtp with pass for passwords
- pkgver = 2.0.5.r0.ga2142eb
- pkgrel = 1
+ pkgdesc = Configure neomutt, isync, getmail and msmtp with pass for passwords (POP3/SMTP)
+ pkgver = 2.0.5.r3.gdc66cf4
+ pkgrel = 2
url = https://github.com/rpuntaie/mailwizard
install = wizard.install
changelog = changelog.txt
@@ -36,4 +36,3 @@ pkgbase = mailwizard-git
sha256sums = 96471dc5a53af342cf14f5ec119df81509617f960c707d732781a24d9e2ed3c6
pkgname = mailwizard-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b44b972786fc..407970f77395 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,19 @@
pkgname=mailwizard-git
+_name="${pkgname%-git}"
-pkgver() {
- cd "${pkgname%-git}"
- git describe --long "$(git rev-list -1 HEAD .)" | sed 's/^v//;s/-/.r/;s/-/./'
-}
-pkgver=2.0.5.r0.ga2142eb
-pkgrel=1
+pkgver() { git -C "$_name" describe --long | sed 's/^v//;s/-/.r/;s/-/./'; }
+pkgver=2.0.5.r3.gdc66cf4
+pkgrel=2
-pkgdesc='Configure neomutt, isync, getmail and msmtp with pass for passwords'
+pkgdesc='Configure neomutt, isync, getmail and msmtp with pass for passwords (POP3/SMTP)'
arch=('x86_64')
-url="https://github.com/rpuntaie/${pkgname%-git}"
+url="https://github.com/rpuntaie/$_name"
license=('GPL3')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}" 'mutt-wizard')
+provides=("$_name")
+conflicts=("$_name" 'mutt-wizard')
makedepends=('git')
depends=('neomutt' 'isync' 'getmail6' 'msmtp' 'notmuch-runtime' 'pass' 'urlscan')
@@ -46,15 +44,15 @@ sha256sums=('SKIP'
#check() {
-# cd "${pkgname%-git}"
+# cd "$_name"
# ./dotests
#}
package() {
- cd "${pkgname%-git}"
+ cd "$_name"
make DESTDIR="$pkgdir" -s install
- install -m755 ../migrationhelper -t"$pkgdir/usr/share/${pkgname%-git}/"
- install -Dm644 README.rst -t"$pkgdir/usr/share/doc/${pkgname%-git}/"
+ install -m755 ../migrationhelper -t"$pkgdir/usr/share/$_name/"
+ install -Dm644 README.rst -t"$pkgdir/usr/share/doc/$_name/"
}