summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Fleckstein2022-09-15 16:41:58 +0200
committerErik Fleckstein2022-09-15 16:41:58 +0200
commit377df6a11c717de7c660eae80074c092de1d31c5 (patch)
tree6be5df876d87ef7c9b9eed5ebbcd4e9698155dbe
parent3a05cef39a8946c82ec8db8ff1445ccc31e4a912 (diff)
downloadaur-377df6a11c717de7c660eae80074c092de1d31c5.tar.gz
Add patch to fix serviceprovider data creation.
-rw-r--r--.SRCINFO4
-rw-r--r--0001-red-Handle-service-provider-country-codes-missing-in.patch36
-rw-r--r--PKGBUILD12
3 files changed, 48 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ecc3cbc4ac3..fc33c4429d93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = brickv
pkgdesc = testing/flashing tool for tinkerforge brick(let)s
pkgver = 2.4.22
- pkgrel = 1
+ pkgrel = 2
url = http://www.tinkerforge.com/
arch = any
license = GPL2
@@ -12,6 +12,8 @@ pkgbase = brickv
depends = python-tzlocal
optdepends = brickd: local device support
source = https://github.com/Tinkerforge/brickv/archive/v2.4.22.zip
+ source = 0001-red-Handle-service-provider-country-codes-missing-in.patch
sha256sums = c09b27e10d2f3bce40d3fb6a3aa8a4bbde51d0b3a6fdc54ce41fca41869f7a72
+ sha256sums = ccedb2964a304cb332fb96e705a4b6e4ab5b40623b019495b42d4ecb817c6dd1
pkgname = brickv
diff --git a/0001-red-Handle-service-provider-country-codes-missing-in.patch b/0001-red-Handle-service-provider-country-codes-missing-in.patch
new file mode 100644
index 000000000000..b04ecb66d5d5
--- /dev/null
+++ b/0001-red-Handle-service-provider-country-codes-missing-in.patch
@@ -0,0 +1,36 @@
+From 38339ae4a102acf13c250aa962d45acae5624b52 Mon Sep 17 00:00:00 2001
+From: Erik Fleckstein <erik@tinkerforge.com>
+Date: Wed, 27 Jul 2022 14:37:49 +0200
+Subject: [PATCH 1/2] red: Handle service provider country codes missing in
+ ISO-3166 database.
+
+---
+ .../plugin_system/plugins/red/build_serviceproviders.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/src/brickv/plugin_system/plugins/red/build_serviceproviders.py b/src/brickv/plugin_system/plugins/red/build_serviceproviders.py
+index 3b7d95ca..87a11c93 100644
+--- a/src/brickv/plugin_system/plugins/red/build_serviceproviders.py
++++ b/src/brickv/plugin_system/plugins/red/build_serviceproviders.py
+@@ -3,7 +3,7 @@
+ """
+ Copyright (C) 2015 Ishraq Ibne Ashraf <ishraq@tinkerforge.com>
+ Copyright (C) 2015 Matthias Bolte <matthias@tinkerforge.com>
+-Copyright (C) 2020 Erik Fleckstein <erik@tinkerforge.com>
++Copyright (C) 2020, 2022 Erik Fleckstein <erik@tinkerforge.com>
+
+ build_serviceproviders.py: Generate python dicts for mobile internet feature
+
+@@ -114,6 +114,9 @@ def main():
+
+ for dict_c in dict_provider['country']:
+ code_country = dict_c['@code']
++ if code_country.upper() not in dict_country_all:
++ print(' Skipping country with code {}: not found in ISO-3166 database'.format(code_country))
++ continue
+ dict_country[code_country] = dict_country_all[code_country.upper()]
+
+ except Exception as e:
+--
+2.37.1
+
diff --git a/PKGBUILD b/PKGBUILD
index ce319c31d25a..16b9e8f0b0fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=brickv
pkgver=2.4.22
-pkgrel=1
+pkgrel=2
pkgdesc="testing/flashing tool for tinkerforge brick(let)s"
url="http://www.tinkerforge.com/"
license=("GPL2")
@@ -13,8 +13,14 @@ arch=('any')
depends=('python-pyserial' 'python-pyqt5' 'python-pytz' 'python-tzlocal')
optdepends=('brickd: local device support')
makedepends=('python-setuptools')
-source=(https://github.com/Tinkerforge/${pkgname}/archive/v${pkgver}.zip)
-sha256sums=('c09b27e10d2f3bce40d3fb6a3aa8a4bbde51d0b3a6fdc54ce41fca41869f7a72')
+source=(https://github.com/Tinkerforge/${pkgname}/archive/v${pkgver}.zip
+ 0001-red-Handle-service-provider-country-codes-missing-in.patch)
+sha256sums=('c09b27e10d2f3bce40d3fb6a3aa8a4bbde51d0b3a6fdc54ce41fca41869f7a72'
+ 'ccedb2964a304cb332fb96e705a4b6e4ab5b40623b019495b42d4ecb817c6dd1')
+
+prepare() {
+ patch --directory="$pkgname-$pkgver" --forward --strip=1 --input="${srcdir}/0001-red-Handle-service-provider-country-codes-missing-in.patch"
+}
build() {
cd $srcdir/$pkgname-$pkgver/src